MariaDB 10.0.x < 10.0.29 多個弱點

medium Nessus Plugin ID 96486
新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 8.9

Synopsis

遠端資料庫伺服器受到多個弱點影響。

描述

遠端主機上安裝的 MariaDB 是 10.0.29 之前的 10.0.x 版。因此,會受到多個弱點影響:- scripts/mysqld_safe.sh 中有一個權限提升弱點,這是因為不當處理向 malloc-lib 提供的引數所致。本機攻擊者可加以惡意利用,透過對錯誤記錄發動符號連結攻擊,來取得 root 權限。(CVE-2016-6664) - check_duplicate_key() 函式中存在一個拒絕服務弱點,這是因不當處理錯誤訊息所致。經驗證的遠端攻擊者可加以惡意利用造成資料庫損毀。- sql/sql_select.cc 的 destroy() 函式存在一個拒絕服務弱點,此弱點是因不當處理特製查詢所導致。經驗證的遠端攻擊者可加以惡意利用造成資料庫損毀。- sql/sql_time.cc 的 date_add_interval() 函式存在一個拒絕服務弱點,此弱點是因不當處理 INTERVAL 引數所導致。經驗證的遠端攻擊者可加以惡意利用造成資料庫損毀。- sql/item_subselect.cc 中有一個拒絕服務弱點,這是因為不當處理 select/unit 樹狀結構的查詢所致。經驗證的遠端攻擊者可加以惡意利用造成資料庫損毀。- sql/item.cc 的 check_well_formed_result() 函式存在一個拒絕服務弱點,此弱點是因不當處理列驗證所導致。經驗證的遠端攻擊者可加以惡意利用造成資料庫損毀。- sql/item.cc 的 safe_charset_converter() 函式存在一個拒絕服務弱點,此弱點是因不當處理特製 subselect 查詢項目所導致。經驗證的遠端攻擊者可加以惡意利用造成資料庫損毀。

解決方案

升級版本至 MariaDB 10.0.29 或更新版本。

另請參閱

https://mariadb.com/kb/en/library/mariadb-10029-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-10029-release-notes/

Plugin 詳細資訊

嚴重性: Medium

ID: 96486

檔案名稱: mariadb_10_0_29.nasl

版本: 1.9

類型: remote

系列: Databases

已發布: 2017/1/13

已更新: 2019/4/10

相依性: mysql_version.nasl, mysql_login.nasl

組態: 啟用 Paranoid 模式

風險資訊

風險因素: Medium

VPR 評分: 8.9

CVSS v2.0

基本分數: 6.9

時間分數: 6

媒介: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

時間媒介: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

基本分數: 7

時間分數: 6.7

媒介: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:H/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:*

必要的 KB 項目: Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2017/1/13

弱點發布日期: 2016/7/17

參考資訊

CVE: CVE-2016-6664

BID: 93612