MariaDB 10.0.x < 10.0.24 多個弱點

medium Nessus Plugin ID 93828

Synopsis

遠端資料庫伺服器受到多個弱點影響。

描述

遠端主機上執行的 MariaDB 版本是早於 10.0.24 的 10.0.x。因此,該應用程式受到多個弱點影響:

- DML 子元件中存在不明缺陷,經驗證的遠端攻擊者可利用此缺陷影響完整性和可用性。(CVE-2016-0640)

- MyISAM 子元件中存在不明缺陷,經驗證的遠端攻擊者可藉以揭露敏感資訊,或造成拒絕服務情形。(CVE-2016-0641)

- DDL 子元件中存在不明缺陷,經驗證的遠端攻擊者可藉以造成拒絕服務情形。(CVE-2016-0644)

- DML 子元件中存在不明缺陷,經驗證的遠端攻擊者可藉以造成拒絕服務情形。(CVE-2016-0646)

- PS 子元件中存在不明缺陷,經驗證的遠端攻擊者可藉以造成拒絕服務情形。(CVE-2016-0649)

- Replication 子元件中存在不明缺陷,經驗證的遠端攻擊者可藉以造成拒絕服務情形。
(CVE-2016-0650)

- InnoDB 子元件中存在一個不明缺陷,經驗證的遠端攻擊者可藉以造成拒絕服務情形。(CVE-2016-0668)

- sql_lex.cc 的 SELECT_LEX::update_used_tables() 函式中存在拒絕服務弱點,這是未正確處理已使用表格更新的 semi-join 情形所致。經驗證的遠端攻擊者可利用此弱點,造成資料庫損毀。

- opt_subselect.cc 的 JOIN::choose_subquery_plan() 函式中存在拒絕服務弱點,這是未正確處理內含 SQ 的巢狀 IN 子句所致。經驗證的遠端攻擊者可利用此弱點,造成資料庫損毀。

- sql_insert.cc 的 select_create::prepare() 函式中存在拒絕服務弱點,這是未正確處理新表格中的已儲存程序所致。
經驗證的遠端攻擊者可利用此弱點,造成資料庫損毀。

- sql_select.cc 中存在拒絕服務弱點,這是在暫存表中不當建立金鑰所致。經驗證的遠端攻擊者可利用此弱點,造成資料庫損毀。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 MariaDB 10.0.24 或更新版本。

另請參閱

https://mariadb.org/mariadb-10-0-24-now-available/

https://mariadb.com/kb/en/library/mariadb-10024-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-10024-release-notes/

Plugin 詳細資訊

嚴重性: Medium

ID: 93828

檔案名稱: mariadb_10_0_24.nasl

版本: 1.9

類型: remote

系列: Databases

已發布: 2016/10/3

已更新: 2019/11/14

組態: 啟用 Paranoid 模式

支持的傳感器: Frictionless Assessment Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 4.9

時間分數: 3.6

媒介: AV:N/AC:M/Au:S/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2016-0641

CVSS v3

風險因素: Medium

基本分數: 5.1

時間分數: 4.5

媒介: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:mariadb:mariadb

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/2/11

弱點發布日期: 2014/11/17

參考資訊

CVE: CVE-2016-0640, CVE-2016-0641, CVE-2016-0644, CVE-2016-0646, CVE-2016-0649, CVE-2016-0650, CVE-2016-0668