MySQL 5.5 < 5.5.30 yaSSL 緩衝區溢位

high Nessus Plugin ID 65734
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端資料庫伺服器受到緩衝區溢位弱點的影響。

描述

遠端主機上安裝的 MySQL 5.5 版本比 5.5.30 舊,因此會受到一個與「yaSSL」相關的緩衝區溢位問題影響。
此錯誤可能允許任意程式碼執行。

解決方案

升級至 MySQL 5.5.30 或更新版本。

另請參閱

https://www.zerodayinitiative.com/advisories/ZDI-13-251/

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html

https://blogs.oracle.com/sunsecurity/cve-2012-0553-buffer-overflow-vulnerability-in-yassl

http://www.nessus.org/u?c79e27db

Plugin 詳細資訊

嚴重性: High

ID: 65734

檔案名稱: mysql_5_5_30.nasl

版本: 1.7

類型: remote

系列: Databases

已發布: 2013/3/29

已更新: 2019/11/27

相依性: mysql_version.nasl, mysql_login.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2013-1492

VPR

風險因素: Medium

分數: 5.8

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:oracle:mysql

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/2/5

弱點發布日期: 2013/3/19

參考資訊

CVE: CVE-2013-1492

BID: 58595