PostgreSQL 8.3 < 8.3.19 / 8.4 < 8.4.12 / 9.0 < 9.0.8 / 9.1 < 9.1.4 多個弱點。

high Nessus Plugin ID 63353

Synopsis

遠端資料庫伺服器受到多個弱點影響。

描述

遠端主機上安裝的 PostgreSQL 版本是比 8.3.19 舊的 8.3.x 版、比 8.4.12 舊的 8.4.x 版、比 9.0.8 舊的 9.0.x 版或比 9.1.4 舊的 9.1.x 版。因此可能受到多個弱點影響:

- 如果使用 DES 加密,則包含位元組 0x80 且傳遞至 pgcrypto 中 crypt() 函式的密碼會遭到不正確地截斷。(CVE-2012-2143)

- 程序呼叫處置程式的 SECURITY_DEFINER 和 SET 屬性不會遭到忽略,而且可以用來使伺服器當機。(CVE-2012-2655)

解決方案

升級至 PostgreSQL 8.3.19 / 8.4.12 / 9.0.8 / 9.1.4 或更新版本。

另請參閱

https://www.postgresql.org/about/news/1398/

https://www.postgresql.org/docs/8.3/release-8-3-19.html

https://www.postgresql.org/docs/8.4/release-8-4-12.html

https://www.postgresql.org/docs/9.0/release-9-0-8.html

https://www.postgresql.org/docs/9.1/release-9-1-4.html

Plugin 詳細資訊

嚴重性: High

ID: 63353

檔案名稱: postgresql_20120604.nasl

版本: 1.14

類型: local

系列: Databases

已發布: 2012/12/28

已更新: 2022/4/11

風險資訊

CVSS 評分資料來源: CVE-2012-2143

VPR

風險因素: Medium

分數: 4

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:postgresql:postgresql

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2012/5/30

弱點發布日期: 2012/5/31

參考資訊

CVE: CVE-2012-2143, CVE-2012-2655

BID: 53729, 53812