PostgreSQL 7.4 < 7.4.29 / 8.0 < 8.0.25 / 8.1 < 8.1.21 / 8.2 < 8.2.17 / 8.3 < 8.3.11 / 8.4 < 8.4.4 多個弱點

high Nessus Plugin ID 63349
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端資料庫伺服器受到多個弱點影響。

描述

遠端主機上安裝的 PostgreSQL 版本是比 7.4.29 舊的 7.4 版、比 8.0.25 舊的 8.0 版、比 8.1.21 舊的 8.1 版、比 8.2.17 舊的 8.2 版、比 8.3.11 舊的 8.3 版或比 8.4.4 舊的 8.4 版。因此可能受到多個弱點影響:

- Safe.pm 和 PL/Perl 中的一個弱點可在已安裝並啟用 PL/Perl 的情況下,允許經驗證的使用者在資料庫伺服器上執行任意 Perl 程式碼。
(CVE-2010-1169)

- pltcl_modules 表格上不安全的權限可在已安裝並啟用 PL/Tcl 的情況下,允許經驗證的使用者在資料庫伺服器上執行任意 Tcl 程式碼。(CVE-2010-1170)

- 無權限的資料庫使用者可以移除超級使用者透過 ALTER USER 套用至使用者帳戶的僅限超級使用者設定,因而繞過應該強制執行的設定。(CVE-2010-1975)

解決方案

升級至 PostgreSQL 7.4.29 / 8.0.25 / 8.1.21 / 8.2.17 / 8.3.11 / 8.4.4 或更新版本。

另請參閱

https://www.postgresql.org/about/news/1203/

https://www.postgresql.org/docs/7.4/release-7-4-29.html

https://www.postgresql.org/docs/8.0/release-8-0-25.html

https://www.postgresql.org/docs/8.1/release-8-1-21.html

https://www.postgresql.org/docs/8.2/release-8-2-17.html

http://www.postgresql.org/docs/8.3/static/release-8-3-11.html

http://www.postgresql.org/docs/8.4/static/release-8-4-4.html

Plugin 詳細資訊

嚴重性: High

ID: 63349

檔案名稱: postgresql_20100517.nasl

版本: 1.9

類型: local

系列: Databases

已發布: 2012/12/28

已更新: 2018/11/15

相依性: postgresql_version.nbin

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 8.5

時間分數: 6.3

媒介: AV:N/AC:M/Au:S/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:postgresql:postgresql

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2010/5/14

弱點發布日期: 2010/5/14

參考資訊

CVE: CVE-2010-1169, CVE-2010-1170, CVE-2010-1975

BID: 40215, 40304