Ubuntu 10.04 LTS / 11.04 / 11.10:python2.6 弱點 (USN-1596-1)

medium Nessus Plugin ID 62436
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性相關修補程式。

描述

據發現,在某些情況下,Python 會在 sys.path 前面加上空字串。具有目前工作目錄寫入權限的本機攻擊者可惡意利用此弱點,執行任意程式碼。(CVE-2008-5983)

據發現,audioop 模組並未正確執行輸入驗證。如果使用者或自動化系統遭誘騙而開啟特製的音訊檔案,攻擊者可透過應用程式損毀而導致拒絕服務。(CVE-2010-1634、CVE-2010-2089)

Giampaolo Rodola 發現 smtpd 模組中有數個爭用情形。遠端攻擊者可惡意利用此弱點,透過程序中斷而導致拒絕服務。(CVE-2010-3493)

據發現,CGIHTTPServer 模組並未針對某些 HTTP GET 要求正確執行輸入驗證。遠端攻擊者可能存取 CGI 指令碼來源檔案。
(CVE-2011-1015)

Niels Heinen 發現,urllib 和 urllib2 模組會處理指定重新導向至 file: URL 的 Location 標頭。遠端攻擊者可惡意利用此弱點,取得敏感資訊或導致拒絕服務。此問題只會影響 Ubuntu 11.04。
(CVE-2011-1521)

據發現,SimpleHTTPServer 並未在 Content-Type HTTP 標頭中使用字元集參數。攻擊者可能惡意利用這點,針對 Internet Explorer 7 使用者進行跨網站指令碼 (XSS) 攻擊。此問題只會影響 Ubuntu 11.04。(CVE-2011-4940)

據發現,Python distutils 在建立 ~/.pypirc 檔案時,包含一個爭用情形。本機攻擊者可能惡意利用此弱點取得敏感資訊。(CVE-2011-4944)

據發現,SimpleXMLRPCServer 在處理 HTTP POST 要求時,並未正確驗證其輸入。遠端攻擊者可惡意利用這點,透過過量的 CPU 使用率而導致拒絕服務。(CVE-2012-0845)

據發現,Python 容易遭受雜湊演算法攻擊。在特定條件下,攻擊者可導致拒絕服務。此更新新增了「-R」命令行選項,並接受針對具有無法預測之值的 salt str 和 datetime 物件將 PYTHONHASHSEED 環境變數設定為「random」。
(CVE-2012-1150)。

解決方案

更新受影響的 python2.6 和/或 python2.6-minimal 套件。

另請參閱

https://usn.ubuntu.com/1596-1/

Plugin 詳細資訊

嚴重性: Medium

ID: 62436

檔案名稱: ubuntu_USN-1596-1.nasl

版本: 1.9

類型: local

代理程式: unix

已發布: 2012/10/5

已更新: 2019/9/19

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.9

時間分數: 5.4

媒介: AV:L/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:canonical:ubuntu_linux:python2.6, p-cpe:/a:canonical:ubuntu_linux:python2.6-minimal, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:11.04, cpe:/o:canonical:ubuntu_linux:11.10

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2012/10/4

弱點發布日期: 2009/1/27

參考資訊

CVE: CVE-2008-5983, CVE-2010-1634, CVE-2010-2089, CVE-2010-3493, CVE-2011-1015, CVE-2011-1521, CVE-2011-4940, CVE-2011-4944, CVE-2012-0845, CVE-2012-1150

USN: 1596-1