MySQL 5.5 < 5.5.22 多個弱點

high Nessus Plugin ID 58661

Synopsis

遠端資料庫伺服器受到多個弱點影響。

描述

遠端主機上安裝的 MySQL 5.5 版本比 5.5.22 舊。因此受到以下弱點影響:

- 存在與內含 yaSSL 元件相關的一個錯誤,其可導致任意程式碼執行。
(CVE-2012-0882)

- 存在與「伺服器最佳化程式」、「伺服器 DML」、「磁碟分割」相關的錯誤,以及可導致拒絕服務攻擊 InnoDB、「HANDLER READ NEXT」。(CVE-2012-1688、CVE-2012-1690、CVE-2012-1697、CVE-2012-1703、CVE-2012-2102)

解決方案

升級至 MySQL 5.5.22 或更新版本。

另請參閱

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-22.html

http://www.nessus.org/u?4225df87

https://www.openwall.com/lists/oss-security/2012/02/24/2

Plugin 詳細資訊

嚴重性: High

ID: 58661

檔案名稱: mysql_5_5_22.nasl

版本: 1.15

類型: remote

系列: Databases

已發布: 2012/4/11

已更新: 2018/11/15

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:mysql:mysql

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2012/3/21

弱點發布日期: 2012/3/21

參考資訊

CVE: CVE-2012-0882, CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102

BID: 51925, 52931, 53058, 53064, 53067, 53074