PostgreSQL 14.x < 14.12 / 15.x < 15.7 / 16.x < 16.3 缺少授權檢查

low Nessus Plugin ID 197741

概要

遠端資料庫伺服器受到一個弱點影響

說明

遠端主機上安裝的 PostgreSQL 是比 14.12 舊的 14 版、比 15.7 舊的 15 版或比 16.3 舊的 16 版。因此,可能會受到一個弱點影響:

- PostgreSQL 內建檢視 pg_stats_ext 和 pg_stats_ext_exprs 中缺少授權,非特權資料庫使用者可從其他使用者的 CREATE STATISTICS 命令中讀取最常見的值和其他統計資料。最常見的值可能會洩漏 eavesdropper 無法讀取的欄值,或其無法執行的函式結果。安裝不受影響的版本只會修正全新的 PostgreSQL 安裝,即在安裝此版本之後使用 initdb 公用程式建立的安裝。在使用者遵循版本資訊中的指示之前,目前的 PostgreSQL 安裝仍會受到影響。在主要版本 14 至 16 中,PostgreSQL 16.3、15.7 和 14.12 之前的次要版本會受到影響。PostgreSQL 14 之前的版本不受影響。(CVE-2024-4317)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 PostgreSQL 14.12/15.7/16.3 或更新版本

另請參閱

http://www.nessus.org/u?07fc5d58

http://www.nessus.org/u?1940556a

Plugin 詳細資訊

嚴重性: Low

ID: 197741

檔案名稱: postgresql_20240509.nasl

版本: 1.1

類型: combined

系列: Databases

已發布: 2024/5/23

已更新: 2024/5/24

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus

風險資訊

VPR

風險因素: Low

分數: 1.4

CVSS v2

風險因素: Low

基本分數: 2.1

時間分數: 1.6

媒介: CVSS2#AV:N/AC:H/Au:S/C:P/I:N/A:N

CVSS 評分資料來源: CVE-2024-4317

CVSS v3

風險因素: Low

基本分數: 3.1

時間分數: 2.7

媒介: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:postgresql:postgresql

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/5/9

弱點發布日期: 2024/5/9

參考資訊

CVE: CVE-2024-4317

IAVB: 2024-B-0062