Oracle MySQL Cluster 7.5.x < 7.5.34 (2024 年 4 月 CPU)

low Nessus Plugin ID 193579

概要

遠端主機受到多個弱點影響

說明

遠端主機上安裝的 MySQL Cluster 版本受到 2024 年 4 月 CPU 公告中提及的多個弱點影響。

- Oracle MySQL 的 MySQL Cluster 產品中存在的弱點 (元件:Cluster: General)。受到影響的支援版本是 7.5.33 與先前的版本、7.6.29 與先前的版本、8.0.36 與先前的版本,以及 8.3.0 與先前的版本。
攻擊此弱點的難度較低,可以透過多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Cluster。若成功攻擊此弱點,攻擊者未經授權即可造成 MySQL Cluster 懸置或經常重複性當機 (完全 DOS)。(CVE-2024-21102)

- Oracle MySQL 的 MySQL Cluster 產品中存在的弱點 (元件:Cluster: General)。受到影響的支援版本是 7.5.33 與先前的版本、7.6.29 與先前的版本、8.0.36 與先前的版本,以及 8.3.0 與先前的版本。
攻擊此弱點的難度較大,透過多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Cluster。若攻擊成功,攻擊者未經授權即可讀取部分 MySQL Cluster 可存取資料。(CVE-2024-21101)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

按照 2024 年 4 月 Oracle 重大修補程式更新公告,套用適當的修補程式。

另請參閱

https://www.oracle.com/docs/tech/security-alerts/cpuapr2024csaf.json

https://www.oracle.com/security-alerts/cpuapr2024.html

Plugin 詳細資訊

嚴重性: Low

ID: 193579

檔案名稱: mysql_cluster_7_5_34.nasl

版本: 1.1

類型: remote

代理程式: windows, macosx, unix

系列: Databases

已發布: 2024/4/19

已更新: 2024/4/22

支援的感應器: Nessus Agent, Nessus

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Low

基本分數: 1.7

時間分數: 1.3

媒介: CVSS2#AV:N/AC:H/Au:M/C:P/I:N/A:N

CVSS 評分資料來源: CVE-2024-21101

CVSS v3

風險因素: Low

基本分數: 2.2

時間分數: 2

媒介: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:oracle:mysql_cluster

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/4/16

弱點發布日期: 2024/4/16

參考資訊

CVE: CVE-2024-21101, CVE-2024-21102

IAVA: 2024-A-0240