MariaDB 10.0.0 < 10.0.2 多個弱點

high Nessus Plugin ID 167854

Synopsis

遠端資料庫伺服器受到多個弱點影響。

描述

遠端主機上安裝的 MariaDB 版本比 10.0.2 舊。因此,會受到 mariadb-10-0-2-release-notes 公告中所提及的多個弱點影響。

- 在 Oracle MySQL 5.1.67 及其之前版本、5.5.29 及其之前版本,以及 MariaDB 5.5.28a (可能還有其他版本) 中,經驗證的遠端使用者可以透過 SELECT 命令和包含具有大量唯一巢狀元素的 XML 的 UpdateXML 命令造成拒絕服務 (mysqld 損毀)。(CVE-2012-5614)

- - 在 Oracle MySQL 5.1.67 及其之前版本、5.5.29 及其之前版本、5.6.10 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Server Locking 相關的未知向量來影響可用性。
(CVE-2013-1506)

- 在 Oracle MySQL 5.5.29 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Data Manipulation Language 相關的未知向量來影響可用性。(CVE-2013-1512)

- 在 Oracle MySQL 5.1.67 及其之前版本、5.5.29 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Server Locking 相關的未知向量來影響機密性、完整性和可用性。(CVE-2013-1521)

- 在 Oracle MySQL 5.5.29 及其之前版本、5.6.10 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Server Optimizer 相關的未知向量來影響機密性、完整性和可用性。(CVE-2013-1523)

- 在 Oracle MySQL 5.5.29 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Server Replication 有關的未知向量影響可用性。(CVE-2013-1526)

- 在 Oracle MySQL 5.1.67 及其之前版本、5.5.29 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過未知向量來影響機密性、完整性和可用性。
(CVE-2013-1552)

- 在 Oracle MySQL 5.1.67 及其之前版本、5.5.29 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Server Partition 相關的未知向量影響可用性。
(CVE-2013-1555)

- 在 Oracle MySQL 5.1.67 及其之前版本、5.5.29 及其之前版本、5.6.10 及其之前版本中,有不明弱點允許經驗證的遠端使用者透過與 Information Schema 相關的未知向量來影響機密性、完整性和可用性。(CVE-2013-2378)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級版本至 MariaDB 10.0.2 或更新版本。

另請參閱

https://mariadb.com/kb/en/mariadb-10-0-2-release-notes

Plugin 詳細資訊

嚴重性: High

ID: 167854

檔案名稱: mariadb_10_0_2.nasl

版本: 1.3

類型: combined

代理程式: windows, macosx, unix

系列: Databases

已發布: 2022/11/18

已更新: 2022/11/21

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.5

CVSS v2

風險因素: Medium

基本分數: 6.5

時間分數: 5.1

媒介: AV:N/AC:L/Au:S/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2013-2378

CVSS v3

風險因素: High

基本分數: 7.4

時間分數: 6.7

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:mariadb:mariadb

必要的 KB 項目: installed_sw/MariaDB

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2013/4/24

弱點發布日期: 2012/12/3

參考資訊

CVE: CVE-2012-5614, CVE-2013-1506, CVE-2013-1512, CVE-2013-1521, CVE-2013-1523, CVE-2013-1526, CVE-2013-1552, CVE-2013-1555, CVE-2013-2378