Slackware Linux 14.0 / 14.1 / 14.2 / 15.0 / 當前版 sudo 弱點 (SSA:2022-309-01)

high Nessus Plugin ID 167045

Synopsis

遠端 Slackware Linux 主機缺少 sudo 的安全性更新。

描述

遠端主機上安裝的 sudo 版本低於 1.9.12p1。因此,它受到 SSA:2022-309-01 公告中提及的一個弱點影響。

- 具有 crypt() 密碼後端的 Sudo 1.8.0 至 1.9.12 中包含 plugins/sudoers/auth/passwd.c 陣列超出邊界錯誤,可導致堆積型緩衝區過度讀取。具有 Sudo 存取權的任意本機使用者只要輸入不超過七個字元的密碼,即可觸發此問題。此問題造成的影響可能因系統程式庫、編譯器和處理器架構而異。(CVE-2022-43995)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級受影響的 sudo 套件。

Plugin 詳細資訊

嚴重性: High

ID: 167045

檔案名稱: Slackware_SSA_2022-309-01.nasl

版本: 1.3

類型: local

已發布: 2022/11/5

已更新: 2022/11/30

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.2

時間分數: 4.6

媒介: AV:L/AC:L/Au:S/C:C/I:N/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-43995

CVSS v3

風險因素: High

基本分數: 7.1

時間分數: 6.2

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:slackware:slackware_linux:sudo, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:14.0, cpe:/o:slackware:slackware_linux:14.1, cpe:/o:slackware:slackware_linux:14.2, cpe:/o:slackware:slackware_linux:15.0

必要的 KB 項目: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

可輕鬆利用: No known exploits are available

弱點發布日期: 2022/11/2

參考資訊

CVE: CVE-2022-43995