Slackware Linux 15.0 / 最新版 mozilla-firefox 多個弱點 (SSA:2022-291-02)

high Nessus Plugin ID 166226

Synopsis

遠端 Slackware Linux 主機缺少 mozilla-firefox 的安全性更新。

描述

遠端主機上安裝的 mozilla-firefox 版本低於 102.4.0esr / 106.0。因此,它受到 SSA:2022-291-02 公告中提及的一個弱點影響。

- 違反同源原則使攻擊者能夠透過 <code>performance.getEntries()</code> 竊取跨來源 URL 項目,進而洩漏重新導向的結果。(CVE-2022-42927)

- 特定類型的配置缺少註解,如果 Garbage Collector 處於特定狀態,此問題可導致記憶體損毀,並可能造成系統當機。(CVE-2022-42928)

- 如果網站以特定方式呼叫 <code>window.print()</code>,則可造成瀏覽器拒絕服務,根據使用者的工作階段還原設定,此情況可能會在瀏覽器重新啟動後持續存在。
(CVE-2022-42929)

- Mozilla 開發人員 Ashley Hale 和 Mozilla Fuzzing 團隊報告 Firefox 105 和 Firefox ESR 102.3 中存在記憶體安全錯誤。其中某些錯誤顯示記憶體遭到損毀,我們推測若有心人士有意操控,可能利用其中部分錯誤執行任意程式碼。(CVE-2022-42932)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級受影響的 mozilla-firefox 套件。

Plugin 詳細資訊

嚴重性: High

ID: 166226

檔案名稱: Slackware_SSA_2022-291-02.nasl

版本: 1.5

類型: local

已發布: 2022/10/18

已更新: 2023/1/4

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-42932

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:slackware:slackware_linux:mozilla-firefox, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

必要的 KB 項目: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

可輕鬆利用: No known exploits are available

弱點發布日期: 2022/10/18

參考資訊

CVE: CVE-2022-42927, CVE-2022-42928, CVE-2022-42929, CVE-2022-42932

IAVA: 2022-A-0435-S