Slackware Linux 15.0 / 最新版 hunspell 弱點 (SSA:2022-235-01)

medium Nessus Plugin ID 164364

Synopsis

遠端 Slackware Linux 主機缺少 hunspell 的安全性更新。

描述

遠端主機上安裝的 hunspell 版本比 1.7.1 舊。因此,會受到 SSA:2022-235-01 公告中提及的一個弱點影響。

- 在 Hunspell 1.7.0 中,suggestmgr.cxx 的 SuggestMgr: : leftcommonsubstring 中有無效的讀取作業。
(CVE-2019-16707)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級受影響的 hunspell 套件。

Plugin 詳細資訊

嚴重性: Medium

ID: 164364

檔案名稱: Slackware_SSA_2022-235-01.nasl

版本: 1.2

類型: local

已發布: 2022/8/23

已更新: 2022/8/23

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-16707

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:slackware:slackware_linux:hunspell, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

必要的 KB 項目: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

可輕鬆利用: No known exploits are available

弱點發布日期: 2019/9/23

參考資訊

CVE: CVE-2019-16707