Apache APISIX < 2.13.1 資訊洩漏弱點

high Nessus Plugin ID 161734

Synopsis

遠端主機上安裝的應用程式缺少供應商提供的安全性更新。

描述

遠端主機上安裝的 Apache APISIX 版本是 2.13.1 之前版本。因此,它可能受到資訊洩漏弱點的影響,這是因為從相依性 lua-resty-jwt 傳回的錯誤訊息中包含敏感資訊,進而導致 jwt-auth 外掛程式中有洩漏使用者私密金鑰的安全性問題。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache APISIX 2.13.1 或更新版本。

另請參閱

https://github.com/apache/apisix/blob/release/2.13/CHANGELOG.md#2131

https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr

Plugin 詳細資訊

嚴重性: High

ID: 161734

檔案名稱: apache_apisix_2_13_1.nasl

版本: 1.2

類型: remote

系列: Misc.

已發布: 2022/6/1

已更新: 2022/6/2

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-29266

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:apisix

必要的 KB 項目: installed_sw/Apache APISIX, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/4/15

弱點發布日期: 2022/4/20

參考資訊

CVE: CVE-2022-29266