MariaDB 10.4.0 < 10.4.18 一個弱點

high Nessus Plugin ID 148827

Synopsis

遠端資料庫伺服器受到一個弱點影響

描述

遠端主機上安裝的 MariaDB 版本比 10.4.18 舊。因此,會受到 mdb-10418-rn 公告中所提及的一個弱點影響。

- 在 MariaDB 10.2.37 之前的 10.2、10.3.28 之前的 10.3、10.4.18 之前的10.4,以及 10.5.9 之前的 10.5 版本中;Percona Server 2021-03-03 及之前的版本中;以及 MySQL wsrep wsrep 2021-03-03 及之前的版本中發現遠端程式碼執行弱點。未受信任的搜尋路徑導致了 eval 插入,因此資料庫 SUPER 使用者可在修改 wsrep_provider 和 wsrep_notify_cmd 之後執行作業系統命令。注意:這不會影響 Oracle 產品。(CVE-2021-27928)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 MariaDB 10.4.18 或更新版本。

另請參閱

https://mariadb.com/kb/en/mdb-10418-rn

Plugin 詳細資訊

嚴重性: High

ID: 148827

檔案名稱: mariadb_10_4_18.nasl

版本: 1.3

類型: remote

系列: Databases

已發布: 2021/4/20

已更新: 2021/4/21

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 9

時間分數: 7

媒介: AV:N/AC:L/Au:S/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-27928

CVSS v3

風險因素: High

基本分數: 7.2

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:mariadb:mariadb

必要的 KB 項目: Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/2/22

弱點發布日期: 2021/3/19

參考資訊

CVE: CVE-2021-27928