MariaDB 10.0.0 < 10.0.13 多個弱點

high Nessus Plugin ID 129359

Synopsis

遠端資料庫伺服器受到多個弱點影響

描述

遠端主機上安裝的 MariaDB 版本比 10.0.13 舊。因此,會受到 mariadb-10013-release-notes 公告中提及的多個弱點影響,包括下列:- OpenSSL 中一個未正確限制 ChangeCipherSpec 訊息處理作業的缺陷。攔截式攻擊者可加以惡意利用,透過特製的 TLS 交握,在特定的 OpenSSL 至 OpenSSL 通訊中強迫使用零長度的主要金鑰,導致工作階段遭劫持及敏感資訊遭洩漏。(CVE-2014-0224) - OpenSSL 中有一個與無效 DTLS 片段處理相關的緩衝區溢位錯誤,可導致任意程式碼執行或拒絕服務。這是因為不當驗證 DTLS ClientHello 訊息中的片段長度所致。(CVE-2014-0195) - MariaDB 伺服器中有一個與 CLIENT:MYSQLDUMP 相關的不明弱點,經驗證的遠端使用者可藉以影響機密性、完整性和可用性。(CVE-2014-6530) 請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 MariaDB 10.0.13 或更新版本。

另請參閱

https://mariadb.com/kb/en/mariadb-10013-release-notes

Plugin 詳細資訊

嚴重性: High

ID: 129359

檔案名稱: mariadb_10_0_13.nasl

版本: 1.6

類型: remote

系列: Databases

已發布: 2019/9/26

已更新: 2022/5/19

組態: 啟用 Paranoid 模式

支持的傳感器: Frictionless Assessment Agent

風險資訊

VPR

風險因素: High

分數: 8.3

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.6

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:F/RL:OF/RC:C

CVSS 評分資料來源: CVE-2014-0195

CVSS v3

風險因素: High

基本分數: 7.4

時間分數: 6.9

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

時間媒介: E:F/RL:O/RC:C

CVSS 評分資料來源: CVE-2014-0224

弱點資訊

CPE: cpe:/a:mariadb:mariadb

必要的 KB 項目: Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2014/8/11

弱點發布日期: 2012/12/3

惡意利用途徑

Core Impact

參考資訊

CVE: CVE-2010-5298, CVE-2012-5615, CVE-2014-0195, CVE-2014-0198, CVE-2014-0221, CVE-2014-0224, CVE-2014-3470, CVE-2014-4274, CVE-2014-4287, CVE-2014-6463, CVE-2014-6474, CVE-2014-6478, CVE-2014-6484, CVE-2014-6489, CVE-2014-6495, CVE-2014-6505, CVE-2014-6520, CVE-2014-6530, CVE-2014-6551, CVE-2014-6564, CVE-2015-0391

BID: 56766, 66801, 67193, 67898, 67899, 67900, 67901, 69732, 70448, 70455, 70462, 70486, 70489, 70496, 70510, 70511, 70516, 70517, 70525, 70532, 72205