MariaDB 10.0.0 < 10.0.15 多個弱點

high Nessus Plugin ID 129355

Synopsis

遠端資料庫伺服器受到多個弱點影響

描述

遠端主機上安裝的 MariaDB 版本比 10.0.15 舊。因此,會受到 mariadb-10015-release-notes 公告中提及的多個弱點所影響。這些弱點包括下列:-「SERVER:OPTIMIZER」元件中的一個不明弱點。經過驗證的遠端攻擊者可藉此影響可用性。(CVE-2014-6469) -「SERVER:SSL:yaSSL」元件中的兩個個別不明弱點。遠端攻擊者可藉以影響機密性、完整性和可用性。(CVE-2014-6491、CVE-2014-6500) 請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級版本至 MariaDB 10.0.15 或更新版本。

另請參閱

https://mariadb.com/kb/en/mariadb-10015-release-notes

Plugin 詳細資訊

嚴重性: High

ID: 129355

檔案名稱: mariadb_10_0_15.nasl

版本: 1.4

類型: remote

系列: Databases

已發布: 2019/9/26

已更新: 2019/10/31

組態: 啟用 Paranoid 模式

支持的傳感器: Frictionless Assessment Agent

風險資訊

VPR

風險因素: Medium

分數: 5.5

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2014-6500

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:mariadb:mariadb

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/11/25

弱點發布日期: 2014/10/15

參考資訊

CVE: CVE-2014-6464, CVE-2014-6469, CVE-2014-6491, CVE-2014-6494, CVE-2014-6496, CVE-2014-6500, CVE-2014-6507, CVE-2014-6555, CVE-2014-6559

BID: 70444, 70446, 70451, 70469, 70478, 70487, 70497, 70530, 70550