libssh 0.6.x / 0.7.x < 0.7.6 / 0.8.x < 0.8.4 驗證繞過 (遠端版本檢查)

critical Nessus Plugin ID 118155

Synopsis

遠端伺服器容易受到驗證繞過影響。

描述

根據其標題版本判斷,遠端 libssh 型伺服器容易受到驗證繞過影響。攻擊者可提供 SSH2_MSG_USERAUTH_SUCCESS 訊息來取代通常可初始化驗證的 SSH2_MSG_USERAUTH_REQUEST 方法,藉此繞過驗證。

請注意,Nessus 未實際測試該缺陷,反而依賴 libssh 標題顯示的版本,因此該缺陷可能為誤判。

解決方案

升級版本至 libssh 0.7.6 / 0.8.4 版或更新版本。

另請參閱

http://www.nessus.org/u?6f6b157e

Plugin 詳細資訊

嚴重性: Critical

ID: 118155

檔案名稱: libssh_0_8_4.nasl

版本: 1.16

類型: remote

系列: Misc.

已發布: 2018/10/17

已更新: 2020/5/15

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2018-10933

VPR

風險因素: High

分數: 7.7

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 8.2

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

必要的 KB 項目: Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

弱點發布日期: 2018/10/16

參考資訊

CVE: CVE-2018-10933

IAVA: 2018-A-0347-S