GLSA-201701-50:PPP:緩衝區溢位

medium Nessus Plugin ID 96685
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Gentoo 主機缺少一個或多個與安全性相關的修補程式。

描述

遠端主機受到 GLSA-201701-50 中所述的弱點影響 (PPP:緩衝區溢位) 在 PPP 中,當 pppd 的 PID 大於 65535 時,在 plugins/radius/util.c 的 rc_mksid 函式內發現緩衝區溢位情形。影響:遠端攻擊者可造成拒絕服務情況。因應措施:目前尚無已知的因應措施。

解決方案

所有 PPP 使用者皆應升級至最新版本:# emerge --sync # emerge --ask --oneshot --verbose '>=net-dialup/ppp-2.4.7-r3'

另請參閱

https://security.gentoo.org/glsa/201701-50

Plugin 詳細資訊

嚴重性: Medium

ID: 96685

檔案名稱: gentoo_GLSA-201701-50.nasl

版本: 3.2

類型: local

已發布: 2017/1/23

已更新: 2021/1/11

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Low

分數: 3.4

CVSS v2

風險因素: Medium

基本分數: 4.3

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

弱點資訊

CPE: p-cpe:/a:gentoo:linux:ppp, cpe:/o:gentoo:linux

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

修補程式發佈日期: 2017/1/23

參考資訊

CVE: CVE-2015-3310

GLSA: 201701-50