OpenSSL 1.1.0 < 1.1.0a 多個弱點

high Nessus Plugin ID 93816
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端服務受到多個弱點的影響。

描述

根據其橫幅,遠端主機正在執行 OpenSSL 1.1.0a 之前的 1.1.0 版。因此,會受到以下弱點影響:- 因為未正確處理來自用戶端的過大 OCSP 狀態要求延伸項目,t1_lib.c 的 ssl_parse_clienthello_tlsext() 函式中存在一個缺陷。未經驗證的遠端攻擊者可加以惡意利用,透過大型 OCSP Status Request 延伸耗盡記憶體資源,進而導致拒絕服務情形。(CVE-2016-6304) - rec_layer_s3.c 的 SSL_peek() 函式中有一個缺陷存在,這是因為不當處理空記錄所致。未經驗證的遠端攻擊者可加以惡意利用,透過觸發 SSL_peek 呼叫中的零長度記錄造成無限迴圈,進而導致拒絕服務情形。(CVE-2016-6305) - 狀態機器實作中有一個拒絕服務弱點存在,這是因為未在配置記憶體之前檢查長度是否過長所致。未經驗證的遠端攻擊者可加以惡意利用,透過特製的 TLS 訊息耗盡記憶體資源。(CVE-2016-6307) - DTLS 實作中有一個拒絕服務弱點存在,這是因為不當處理過長 DTLS 訊息所致。未經驗證的遠端攻擊者可加以惡意利用,透過特製的 DTLS 訊息耗盡可用的記憶體資源。(CVE-2016-6308) - GOST 加密套件中存在一個缺陷,這是因為使用長期金鑰建立加密連線所致。攔截式攻擊者可加以惡意利用,透過 Key Compromise Impersonation (KCI) 攻擊模擬伺服器。

解決方案

升級至 OpenSSL 1.1.0a 版或更新版本。請注意,供應商尚未於官方版本中修復 GOST ciphersuites 弱點;不過該問題的修補程式已傳送至 OpenSSL github 存放庫。

另請參閱

https://www.openssl.org/news/secadv/20160922.txt

http://www.nessus.org/u?09b29b30

Plugin 詳細資訊

嚴重性: High

ID: 93816

檔案名稱: openssl_1_1_0a.nasl

版本: 1.8

類型: remote

系列: Web Servers

已發布: 2016/9/30

已更新: 2019/11/14

相依性: openssl_version.nasl

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 6.1

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:openssl:openssl

必要的 KB 項目: openssl/port

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2016/9/22

弱點發布日期: 2015/8/10

參考資訊

CVE: CVE-2016-6304, CVE-2016-6305, CVE-2016-6307, CVE-2016-6308

BID: 93149, 93150, 93151, 93152