PHP 7.0.x < 7.0.10 多個弱點

critical Nessus Plugin ID 93078
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

描述

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 7.0.10 之前的 7.0.x 版。因此,會受到多個弱點影響:

- interface.c 的 curl_escape() 函式存在一個因不當處理過長字串而導致的溢位情形。未經驗證的遠端攻擊者可惡意利用此問題造成堆積型緩衝區溢位,進而導致拒絕服務情形,或是執行任意程式碼。(VulnDB 143095)

- zend_alloc.c 中的 zend_mm_realloc_heap() 函式存在整數溢位,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此瑕疵來造成緩衝區溢位,進而導致拒絕服務情形或任意程式碼執行。
(VulnDB 143115)

解決方案

升級為 PHP 7.0.10 或更新版本。

另請參閱

http://php.net/ChangeLog-7.php#7.0.10

Plugin 詳細資訊

嚴重性: Critical

ID: 93078

檔案名稱: php_7_0_10.nasl

版本: 1.12

類型: remote

系列: CGI abuses

已發布: 2016/8/23

已更新: 2020/4/27

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2016-7134

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/8/18

弱點發布日期: 2016/8/3

參考資訊

CVE: CVE-2016-7124, CVE-2016-7125, CVE-2016-7126, CVE-2016-7127, CVE-2016-7128, CVE-2016-7129, CVE-2016-7130, CVE-2016-7131, CVE-2016-7132, CVE-2016-7133, CVE-2016-7134

BID: 92552, 92564, 92755, 92756, 92757, 92758, 92764, 92765, 92766, 92767, 92768