FreeBSD:perl -- 本機任意程式碼執行 (72bfbb09-5a6a-11e6-a6c3-14dae9d210b8)

high Nessus Plugin ID 92741

概要

遠端 FreeBSD 主機缺少一個或多個安全性相關更新。

說明

Sawyer X 報告:

Perl 5.22.3-RC2 之前的 5.x 版和 5.24.1-RC2 之前的 5.24 版未正確移除來自目錄陣列結尾的 .(句點) 字元,這可能會允許本機使用者透過目前工作目錄下的特洛伊木馬模組取得權限。

解決方案

更新受影響的套件。

另請參閱

http://www.nessus.org/u?34d06de1

http://www.nessus.org/u?f264f124

Plugin 詳細資訊

嚴重性: High

ID: 92741

檔案名稱: freebsd_pkg_72bfbb095a6a11e6a6c314dae9d210b8.nasl

版本: 2.9

類型: local

已發布: 2016/8/5

已更新: 2021/1/4

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.2

媒介: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3

風險因素: High

基本分數: 7.8

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

弱點資訊

CPE: p-cpe:/a:freebsd:freebsd:perl, p-cpe:/a:freebsd:freebsd:perl5, p-cpe:/a:freebsd:freebsd:perl5-devel, p-cpe:/a:freebsd:freebsd:perl5.18, p-cpe:/a:freebsd:freebsd:perl5.20, p-cpe:/a:freebsd:freebsd:perl5.22, p-cpe:/a:freebsd:freebsd:perl5.24, cpe:/o:freebsd:freebsd

必要的 KB 項目: Host/FreeBSD/release, Host/FreeBSD/pkg_info, Host/local_checks_enabled

修補程式發佈日期: 2016/8/4

弱點發布日期: 2016/7/21

參考資訊

CVE: CVE-2016-1238