PHP 5.5.x < 5.5.38 多個弱點 (httpoxy)

critical Nessus Plugin ID 92554
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

描述

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 5.5.38 之前的 5.5.x 版。因此,會受到多個弱點影響:

- 存在一個攔截式弱點 (稱為「httpoxy」),此弱點是因無法正確依據 RFC 3875 第 4.1.18 節解決命名空間衝突所導致。HTTP_PROXY 環境變數是依據 HTTP 要求的「Proxy」標頭中不受信任的使用者資料所設定。某些 Web 用戶端程式庫會使用 HTTP_PROXY 環境變數來指定遠端代理伺服器。未經驗證的遠端攻擊者可惡意利用此問題,透過 HTTP 要求中的特製「Proxy」標頭,將應用程式的內部 HTTP 流量重新導向至其可觀察或操控的任意代理伺服器。(CVE-2016-5385)

- 檔案 ext/bz2/bz2.c 中的 php_bz2iop_read() 函式存在一個溢位情形,這是因不當處理錯誤情形所導致。未經驗證的遠端攻擊者可惡意利用此問題,透過特製要求執行任意程式碼。(CVE-2016-5399)

- GD Graphics Library (libgd) 中存在一個瑕疵 (具體而言是在檔案 gd_interpolation.c 的 gdImageScaleTwoPass() 函式中),此瑕疵是因不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(CVE-2016-6207)

- 檔案 Zend/zend_virtual_cwd.c 中的 virtual_file_ex() 函式存在一個整數溢位情形,這是因不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(CVE-2016-6289)

- 處理「var_hash」解構時檔案 ext/session/session.c 中存在一個釋放後使用錯誤。未經驗證的遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,進而導致執行任意程式碼。
(CVE-2016-6290)

- 檔案 ext/exif/exif.c 中的 exif_process_IFD_in_MAKERNOTE() 函式存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,進而造成拒絕服務情形或是洩漏記憶體內容。(CVE-2016-6291)

- 檔案 ext/exif/exif.c 中的 exif_process_user_comment() 函式存在一個 NULL 指標解除參照瑕疵。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。
(CVE-2016-6292)

- 檔案 ext/intl/locale/locale_methods.c 中的 locale_accept_from_http() 函式存在多個超出邊界讀取錯誤。未經驗證的遠端攻擊者可惡意利用這些錯誤,造成拒絕服務情形或是洩漏記憶體內容。
(CVE-2016-6293、CVE-2016-6294)

- 在還原序列化使用者提供的輸入期間,處理記憶體回收時,檔案 ext/snmp/snmp.c 中存在一個釋放後使用錯誤。未經驗證的遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,進而導致執行任意程式碼。(CVE-2016-6295)

- 檔案 simplestring.c 中的 simplestring_addn() 函式存在一個堆積型緩衝區溢位情形,此情形是因不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(CVE-2016-6296)

- 檔案 ext/zip/zip_stream.c 中的 php_stream_zip_opener() 函式存在一個整數溢位情形,此情形是因處理 zip 資料流時不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(CVE-2016-6297)

- 處理透明顏色時 GD Graphics Library (libgd) 中存在一個超出邊界讀取錯誤 (具體而言是在檔案 gd_interpolation.c 的 gdImageScaleBilinearPalette() 函式中)。未經驗證的遠端攻擊者可加以惡意利用,進而造成拒絕服務情形或是洩漏記憶體內容。(VulnDB 141674)

- 檔案 ext/mcrypt/mcrypt.c 中的 mdecrypt_generic() 函式存在一個堆積型緩衝區溢位情形,此情形是因不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(VulnDB 141953)

- GD Graphics Library (libgd) 中的 gdImageColorTransparent() 函式存在一個 NULL 寫入瑕疵,此瑕疵是因不當處理負透明顏色所導致。遠端攻擊者可惡意利用此瑕疵來洩漏記憶體內容。(VulnDB 142104)

- php_url_prase_ex() 函式中存在一個溢位情形,這是因為不當驗證使用者提供的輸入所導致。遠端攻擊者可惡意利用此問題,造成緩衝區溢位,進而導致拒絕服務情形。(VulnDB 142133)

解決方案

升級為 PHP 5.5.38 或更新版本。

另請參閱

https://httpoxy.org

http://php.net/ChangeLog-5.php#5.5.38

Plugin 詳細資訊

嚴重性: Critical

ID: 92554

檔案名稱: php_5_5_38.nasl

版本: 1.18

類型: remote

系列: CGI abuses

已發布: 2016/7/26

已更新: 2019/11/14

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2016-6290

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: No exploit is required

修補程式發佈日期: 2016/7/21

弱點發布日期: 2016/7/18

參考資訊

CVE: CVE-2016-6293, CVE-2015-8879, CVE-2016-5399, CVE-2016-6288, CVE-2016-6289, CVE-2016-6290, CVE-2016-6291, CVE-2016-6296, CVE-2016-6297, CVE-2016-6207, CVE-2016-6294, CVE-2016-6292, CVE-2016-6295, CVE-2016-5385

BID: 91821, 92074, 92099, 92051, 92111, 92097, 92073, 92095, 92078, 92094, 90842

CERT: 797896

EDB-ID: 40155