Apache 2.4.18 / 2.4.20 X.509 憑證驗證繞過

high Nessus Plugin ID 92320

Synopsis

遠端網頁伺服器受到驗證繞過弱點影響。

描述

根據其標題,遠端主機上執行的 Apache 版本是 2.4.18 或 2.4.20。此外,HTTP/2 已在 TLS 或 SSL 上啟用。因此受到 HTTP/2 通訊協定實驗模組中的驗證繞過弱點影響,這是因為無法正確驗證 X.509 憑證所導致,會允許存取原本不允許存取的資源。未經驗證的遠端攻擊者可利用此弱點洩露潛在敏感資訊。

解決方案

升級至 Apache 2.4.23 或更新版本。或者,暫時的因應措施,可透過變更組態來停用 HTTP/2,方法是將「h2」和「h2c」從設定檔的通訊協定行移除。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.23

https://httpd.apache.org/security/vulnerabilities_24.html

https://seclists.org/fulldisclosure/2016/Jul/11

Plugin 詳細資訊

嚴重性: High

ID: 92320

檔案名稱: apache_2_4_23.nasl

版本: 1.13

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2016/7/15

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2016-4979

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/7/5

弱點發布日期: 2016/7/5

參考資訊

CVE: CVE-2016-4979

BID: 91566