PHP 5.5.x < 5.5.37 多個弱點

critical Nessus Plugin ID 91897

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

描述

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 5.5.37 之前的 5.5.x 版。因此,會受到多個弱點影響:

- 處理內含過大負座標的特製影像時,file gd.c 內 gdImageFillToBorder() 函式的 GD 圖形程式庫中存在一個拒絕服務弱點。未經驗證的遠端攻擊者可惡意利用此問題,透過特製影像損毀連結至程式庫的處理程序。
(CVE-2015-8874)

- 檔案 ext/gd/libgd/gd_gd2.c 中的
_gd2GetHeader() 函式存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(CVE-2016-5766)

- 檔案 ext/gd/libgd/gd.c 中的
gdImagePaletteToTrueColor() 函式存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(CVE-2016-5767)

- 處理失敗的回呼執行時,
檔案 ext/mbstring/php_mbregex.c 中的 _php_mb_regex_ereg_replace_exec() 函式存在一個重複釋放錯誤。未經驗證的遠端攻擊者可利用此弱點執行任意程式碼。
(CVE-2016-5768)

- 檔案 ext/mcrypt/mcrypt.c 中存在一個整數溢位情形,這是因為處理資料值時不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。(CVE-2016-5769)

- 檔案 ext/spl/spl_directory.c 中存在一個整數溢位情形,由 int/size_t 類型混淆錯誤觸發,允許未經驗證的遠端攻擊者造成不明影響。
(CVE-2016-5770)

- 檔案 ext/spl/spl_array.c 中的記憶體回收演算法存在一個釋放後使用錯誤。未經驗證的遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,進而導致執行任意程式碼。(CVE-2016-5771)

- 處理特製 XML 內容時,檔案 ext/wddx/wddx.c 中的 php_wddx_process_data() 函式存在一個重複釋放錯誤。未經驗證的遠端攻擊者可利用此弱點執行任意程式碼。
(CVE-2016-5772)

- 檔案 ext/zip/php_zip.c 中的記憶體回收演算法存在一個釋放後使用錯誤。未經驗證的遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,進而導致執行任意程式碼。(CVE-2016-5773)

- 檔案 ext/standard/php_smart_str.h 中的 json_decode() 和 json_utf8_to_utf16() 函式存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此引發拒絕服務情形或執行任意程式碼。
(VulnDB 140378)

- 檔案 ext/gd/libgd/gd_topal.c 中的 pass2_no_dither() 函式存在一個超出邊界讀取錯誤,允許未經驗證的遠端攻擊者造成拒絕服務情形或洩漏記憶體內容。(VulnDB 140379)

- 處理字串長度時,檔案 ext/standard/string.c 中存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用這點而造成不明影響。(VulnDB 140380)

- 檔案 ext/gd/libgd/gd_interpolation.c 中的
_gdScaleVert() 函式存在一個 NULL 指標解除參照瑕疵,該瑕疵會於處理 _gdContributionsCalc 傳回值時觸發。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(VulnDB 140382)

- 檔案 ext/standard/string.c 中的 nl2br() 函式處理 new_length 值時存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用這點而造成不明影響。
(VulnDB 140385)

- 處理字串值時,檔案 ext/standard/string.c 中的多個函式存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用這點而造成不明影響。
(VulnDB 140386)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.5.37 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.5.37

Plugin 詳細資訊

嚴重性: Critical

ID: 91897

檔案名稱: php_5_5_37.nasl

版本: 1.16

類型: remote

系列: CGI abuses

已發布: 2016/7/1

已更新: 2022/4/11

風險資訊

CVSS 評分資料來源: CVE-2016-5768

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2016/6/23

弱點發布日期: 2014/1/2

參考資訊

CVE: CVE-2015-8874, CVE-2016-5766, CVE-2016-5767, CVE-2016-5768, CVE-2016-5769, CVE-2016-5770, CVE-2016-5771, CVE-2016-5772, CVE-2016-5773

BID: 90714, 91393, 91395, 91396, 91397, 91398, 91399, 91401, 91403