Zabbix < 2.0.18 / 2.2.13 / 3.0.3「mysql.size」參數命令插入

high Nessus Plugin ID 91349

Synopsis

遠端 Web 應用程式受到一個命令插入弱點影響。

描述

根據其自我報告的版本號碼,遠端主機上執行的 Zabbix 的執行個體會受到一個命令插入弱點影響,這是因為不當清理使用者對「mysql.size」使用者參數提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用此弱點插入任意 shell 命令。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Zabbix 2.0.18 / 2.2.13 / 3.0.3 或更新版本。

另請參閱

https://support.zabbix.com/browse/ZBX-10741

https://www.zabbix.com/rn/rn2.0.18

https://www.zabbix.com/rn/rn2.2.13

https://www.zabbix.com/rn/rn3.0.3

Plugin 詳細資訊

嚴重性: High

ID: 91349

檔案名稱: zabbix_frontend_2_0_18.nasl

版本: 1.12

類型: remote

系列: CGI abuses

已發布: 2016/5/27

已更新: 2022/4/11

組態: 啟用 Paranoid 模式, 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2016-4338

CVSS v3

風險因素: High

基本分數: 8.1

時間分數: 7.3

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:zabbix:zabbix

必要的 KB 項目: installed_sw/zabbix, Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2016/5/18

弱點發布日期: 2016/5/18

參考資訊

CVE: CVE-2016-4338

BID: 89631

EDB-ID: 39769

IAVB: 2016-B-0095-S