RHEL 6:ntp (RHSA-2016: 0780)

high Nessus Plugin ID 91076

Synopsis

遠端 Red Hat 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 6 的 ntp 更新。

Red Hat 產品安全性團隊已將此更新評等為具有「中等」安全性影響。可從〈參照〉一節的 CVE 連結中取得每個弱點之常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

網路時間通訊協定 (NTP) 可用來同步電腦的時間與另一個參照的時間來源。這些套件包括 ntpd 服務,其會持續調整系統時間,以及用來查詢和設定 ntpd 服務的公用程式。

安全性修正:

* 據發現,CVE-2014-9750 的修正並不完整:在 NTP 之 ntp_crypto.c 的值長度檢查中發現三個問題,具有特定自動金鑰作業且包含惡意資料的封包並非每一次都經過完整驗證。遠端攻擊者可使用特製 NTP 封包造成 ntpd 損毀。
(CVE-2015-7691、CVE-2015-7692、CVE-2015-7702)

* 在 ntpd 的 CRYPTO_ASSOC 中發現一個記憶體洩漏瑕疵。如果 ntpd 設為使用自動金鑰驗證,攻擊者即可傳送封包至 ntpd,並且連續數天發動攻擊,從而造成其記憶體不足。(CVE-2015-7701)

* 在 ntpq 的 cookedprint 功能中發現一個差一缺陷,其可導致緩衝區溢位。特別建構的 NTP 封包可能造成 ntpq 損毀。(CVE-2015-7852)

* 在 ntpd 處理「ntpdc reslist」命令 (可查詢具有大量項目的限制清單) 的方式中發現一個 NULL 指標解除參照缺陷。遠端攻擊者可能利用此缺陷造成 ntpd 損毀。(CVE-2015-7977)

* 在 ntpd 處理「ntpdc reslist」命令 (可查詢具有大量項目的限制清單) 的方式中發現一個堆疊型緩衝區溢位缺陷。遠端攻擊者可利用此缺陷造成 ntpd 損毀。(CVE-2015-7978)

* 據發現,ntpd 在處理異常 logconfig 組態命令時可能會因未初始化的變數而損毀。
(CVE-2015-5194)

* 據發現,當在編譯期間未啟用的統計資料類型 (
如 timingstats) 受到統計資料或 filegen 組態命令參照時,ntpd 會因分割錯誤而結束。(CVE-2015-5195)

* 據發現,處理特別建構的 NTP 封包時,sntp 公用程式會因在無限迴圈中被擷取而停止回應。(CVE-2015-5219)

* 據發現,NTP 的:config 命令可用於設定 pidfile 和 driftfile 路徑,而無任何限制。遠端攻擊者可利用此缺陷,將檔案系統上的檔案覆寫為含有 ntpd 處理程序 pid 的檔案 (立即),或是系統時鐘目前的預估偏離 (以小時為間隔)。
(CVE-2015-7703)

CVE-2015-5219 和 CVE-2015-7703 問題由 Red Hat 的 Miroslav Lichvar (Red Hat) 發現。

如需有關此發行版本的詳細變更資訊,請參閱可從〈參照〉一節連結的 Red Hat Enterprise Linux 6.8 版本說明與 Red Hat Enterprise Linux 6.8 技術提示。

解決方案

更新受影響的套件。

另請參閱

https://access.redhat.com/errata/RHSA-2016:0780

https://access.redhat.com/security/cve/cve-2015-5194

https://access.redhat.com/security/cve/cve-2015-5195

https://access.redhat.com/security/cve/cve-2015-5219

https://access.redhat.com/security/cve/cve-2015-7691

https://access.redhat.com/security/cve/cve-2015-7692

https://access.redhat.com/security/cve/cve-2015-7701

https://access.redhat.com/security/cve/cve-2015-7702

https://access.redhat.com/security/cve/cve-2015-7703

https://access.redhat.com/security/cve/cve-2015-7852

https://access.redhat.com/security/cve/cve-2015-7977

https://access.redhat.com/security/cve/cve-2015-7978

https://www.tenable.com/security/research/tra-2015-04

Plugin 詳細資訊

嚴重性: High

ID: 91076

檔案名稱: redhat-RHSA-2016-0780.nasl

版本: 2.19

類型: local

代理程式: unix

已發布: 2016/5/12

已更新: 2020/6/22

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:redhat:enterprise_linux:ntp, p-cpe:/a:redhat:enterprise_linux:ntp-debuginfo, p-cpe:/a:redhat:enterprise_linux:ntp-doc, p-cpe:/a:redhat:enterprise_linux:ntp-perl, p-cpe:/a:redhat:enterprise_linux:ntpdate, cpe:/o:redhat:enterprise_linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/5/10

弱點發布日期: 2017/1/30

參考資訊

CVE: CVE-2015-5194, CVE-2015-5195, CVE-2015-5219, CVE-2015-7691, CVE-2015-7692, CVE-2015-7701, CVE-2015-7702, CVE-2015-7703, CVE-2015-7852, CVE-2015-7977, CVE-2015-7978