RHEL 6 : file (RHSA-2016:0760)

high Nessus Plugin ID 91074
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Red Hat 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 6 的 file 更新。

Red Hat 產品安全性團隊已將此更新評等為具有中等安全性影響。可從〈參照〉一節的 CVE 連結中取得每個弱點之常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

檔案命令用於根據檔案所包含的資料類型來來識別特定檔案。其可識別許多不同的檔案類型,包括可執行和可連結格式 (ELF) 二進位檔案、系統程式庫、RPM 套件和不同圖形格式。

安全性修正:

* 在用來偵測多種檔案的檔案規則運算式規則中發現多個瑕疵。遠端攻擊者可利用這些瑕疵,使檔案消耗過量的 CPU。(CVE-2014-3538)

* 在 file 解析某些 Composite Document Format (CDF) 檔案的方式中發現一個拒絕服務瑕疵。遠端攻擊者可利用此瑕疵,透過特製的 CDF 檔案損毀 file。
(CVE-2014-3587)

* 在 file 剖析可執行且可連結格式 (ELF) 檔案的方式中發現多個瑕疵。遠端攻擊者可利用這些瑕疵,造成檔案損毀、洩漏部分記憶體,或消耗過量的系統資源。(CVE-2014-3710、CVE-2014-8116、CVE-2014-8117、CVE-2014-9620、CVE-2014-9653)

Red Hat 要感謝 Thomas Jarosch (Intra2net AG) 報告 CVE-2014-8116 和 CVE-2014-8117。CVE-2014-3538 問題是由 Jan Kaluza (Red Hat Web 堆疊團隊) 所發現,而 CVE-2014-3710 問題則是由 Francisco Alonso (Red Hat Product Security) 發現。

如需有關此發行版本的詳細變更資訊,請參閱可從〈參照〉一節連結的 Red Hat Enterprise Linux 6.8 版本資訊與 Red Hat Enterprise Linux 6.8 技術提示。

解決方案

更新受影響的套件。

另請參閱

https://access.redhat.com/errata/RHSA-2016:0760

https://access.redhat.com/security/cve/cve-2014-3538

https://access.redhat.com/security/cve/cve-2014-3587

https://access.redhat.com/security/cve/cve-2014-3710

https://access.redhat.com/security/cve/cve-2014-8116

https://access.redhat.com/security/cve/cve-2014-8117

https://access.redhat.com/security/cve/cve-2014-9620

https://access.redhat.com/security/cve/cve-2014-9653

Plugin 詳細資訊

嚴重性: High

ID: 91074

檔案名稱: redhat-RHSA-2016-0760.nasl

版本: 2.10

類型: local

代理程式: unix

已發布: 2016/5/12

已更新: 2019/10/24

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 4.2

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:redhat:enterprise_linux:file, p-cpe:/a:redhat:enterprise_linux:file-debuginfo, p-cpe:/a:redhat:enterprise_linux:file-devel, p-cpe:/a:redhat:enterprise_linux:file-libs, p-cpe:/a:redhat:enterprise_linux:file-static, p-cpe:/a:redhat:enterprise_linux:python-magic, cpe:/o:redhat:enterprise_linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/5/10

弱點發布日期: 2014/7/3

參考資訊

CVE: CVE-2014-3538, CVE-2014-3587, CVE-2014-3710, CVE-2014-8116, CVE-2014-8117, CVE-2014-9620, CVE-2014-9653

RHSA: 2016:0760