PHP 5.5.x < 5.5.35 多個弱點

critical Nessus Plugin ID 90920

概要

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

說明

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 5.5.35 之前的 5.5.x 版。因此,會受到多個弱點影響:

- GD Graphics Library (file gd_gd2.c 內) 存在一個正負號錯誤,這是因為處理壓縮的 GD2 資料時,不當驗證使用者提供的輸入所導致。
未經驗證的遠端攻擊者可惡意利用此問題造成堆積型緩衝區溢位,進而導致拒絕服務情形,或是執行任意程式碼。(CVE-2016-3074)

- 處理 zif_grapheme_stripos() 函式中的負位移時,ext/intl/grapheme/grapheme_string.c 檔案內存在一個超出邊界讀取錯誤。
未經驗證的遠端攻擊者可加以惡意利用,進而造成拒絕服務情形或是洩漏記憶體內容。(VulnDB 137781)

- 處理負比例時,ext/bcmath/bcmath.c 檔案內的 php_str2num() 函式中存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可惡意利用此錯誤,造成拒絕服務情形或是洩漏記憶體內容。(VulnDB 137782)

- 處理 exif 標頭時,ext/exif/exif.c 檔案內的 exif_read_data() 函式中存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可惡意利用此錯誤,造成拒絕服務情形或是洩漏記憶體內容。
(VulnDB 137783)

- 處理特製 XML 內容時,ext/xml/xml.c 檔案內的 xml_parse_into_struct() 函式中存在一個瑕疵。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(VulnDB 137784)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.5.35 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.5.35

Plugin 詳細資訊

嚴重性: Critical

ID: 90920

檔案名稱: php_5_5_35.nasl

版本: 1.16

類型: remote

系列: CGI abuses

已發布: 2016/5/5

已更新: 2024/5/31

組態: 啟用徹底檢查

支援的感應器: Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS 評分資料來源: CVE-2016-3074

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

排除在外的 KB 項目: Settings/disable_cgi_scanning

可被惡意程式利用: true

可輕鬆利用: No exploit is required

修補程式發佈日期: 2016/4/28

弱點發布日期: 2016/4/21

參考資訊

CVE: CVE-2016-3074, CVE-2016-4537, CVE-2016-4538, CVE-2016-4539, CVE-2016-4540, CVE-2016-4541, CVE-2016-4542, CVE-2016-4543, CVE-2016-4544