PHP 7.0.x < 7.0.5 多個弱點

critical Nessus Plugin ID 90362
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器上的 PHP 版本受到多個弱點影響。

描述

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 7.0.5 之前的 7.0.x 版。因此,會受到多個弱點影響:

- finfo_open() 函式中存在一個緩衝區過度寫入情形,這是因為不當驗證 magic 檔案所導致。未經驗證的遠端攻擊者可惡意利用此問題,透過特製的檔案,造成拒絕服務,或是執行任意程式碼。(VulnDB 122863)

- 檔案 ext/snmp/snmp.c 中的 php_snmp_error() 函式存在一個瑕疵,該瑕疵會在處理格式字串指定名稱時觸發。未經驗證的遠端攻擊者可惡意利用此問題,透過特製的 SNMP 物件,造成拒絕服務,或是執行任意程式碼。(VulnDB 136483)

- 處理 phar 檔案名稱的路徑時存在一個無效的記憶體寫入錯誤,允許攻擊者造成不明影響。(VulnDB 136484)

- 處理負參數值時,檔案 ext/mbstring/libmbfl/mbfl/mbfilter.c 中的 mbfl_strcut() 函式存在一個瑕疵。未經驗證的遠端攻擊者可惡意利用此瑕疵,造成拒絕服務。
(VulnDB 136485)

- 檔案 ext/standard/url.c 中的 php_raw_url_encode() 函式存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。未經驗證的遠端攻擊者可惡意利用這點而造成不明影響。
(VulnDB 136486)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 7.0.5 或更新版本。

另請參閱

http://php.net/ChangeLog-7.php#7.0.5

Plugin 詳細資訊

嚴重性: Critical

ID: 90362

檔案名稱: php_7_0_5.nasl

版本: 1.14

類型: remote

系列: CGI abuses

已發布: 2016/4/6

已更新: 2019/11/20

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2016-4073

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: No exploit is required

修補程式發佈日期: 2016/3/31

弱點發布日期: 2015/6/3

參考資訊

CVE: CVE-2015-8865, CVE-2016-4070, CVE-2016-4071, CVE-2016-4072, CVE-2016-4073

EDB-ID: 39645, 39653