Apache Struts 2.x < 2.3.28 多個弱點 (S2-028) (S2-029) (S2-030) (S2-034)

high Nessus Plugin ID 90153

Synopsis

遠端主機上執行的 Web 應用程式使用受多個弱點影響的 Java 架構

描述

遠端主機上執行的 Apache Struts 版本是比 2.3.28 舊的 2.x 版。因此,該應用程式受到以下弱點影響:
- 有一個跨網站指令碼弱點,這是由於在使用單一位元組網頁編碼時錯誤驗證使用者提供的輸入而導致。遠端攻擊者可透過包含多位元組字元的非規格 URL 編碼參數值惡意利用此弱點。(CVE-2016-4003)

- 存在一個遠端程式碼執行弱點,這是因為指派給特定標籤的屬性值發生雙重 OGNL 評估所導致。未經驗證的遠端攻擊者可惡意利用此弱點,透過特製的要求來執行任意程式碼。(CVE-2016-0785)

- 存在一個跨網站指令碼弱點,這是因為在使用 I18NInterceptor 時,不當驗證使用者提供的輸入所導致。遠端攻擊者可惡意利用此弱點,透過特製的要求在使用者的瀏覽器工作階段中執行任意指令碼。(CVE-2016-2162)

- 在 Object-Graph Navigation Language (OGNL) 元件中存在一個拒絕服務弱點,這是因為實作已儲存之方法參照的快取時的一個瑕疵所導致。內容相依的攻擊者可惡意利用此弱點,封鎖對任意網站的存取。
(CVE-2016-3093)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.3.28 或更新版本。或者,套用供應商公告中提及的因應措施。

另請參閱

https://struts.apache.org/docs/s2-028.html

https://struts.apache.org/docs/s2-029.html

https://struts.apache.org/docs/s2-030.html

https://struts.apache.org/docs/s2-034.html

http://struts.apache.org/docs/version-notes-2328.html

Plugin 詳細資訊

嚴重性: High

ID: 90153

檔案名稱: struts_2_3_28_win_local.nasl

版本: 1.17

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2016/3/24

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 9

時間分數: 6.7

媒介: AV:N/AC:L/Au:S/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2016-0785

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:struts

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/3/22

弱點發布日期: 2016/3/15

參考資訊

CVE: CVE-2016-0785, CVE-2016-2162, CVE-2016-3093, CVE-2016-4003

BID: 85066, 85070, 86311, 90961