PHP 5.5.x < 5.5.33 多個弱點

critical Nessus Plugin ID 90007
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 5.5.33 之前的 5.5.x 版。因此,會受到多個弱點影響:

- 處理 XML 資料時,檔案 ext/wddx/wddx.c 的 php_wddx_pop_element() 函式中存在一個釋放後使用錯誤。未經驗證的遠端攻擊者可惡意利用此錯誤,透過特製 XML 資料解除參照已釋放的記憶體,進而導致任意程式碼執行。
(CVE-2016-3141)

- 檔案 ext/phar/zip.c 的 phar_parse_zipfile() 函式中存在一個超出邊界讀取錯誤,其允許未經驗證的遠端攻擊者造成拒絕服務,或是取得敏感資訊的存取權。(CVE-2016-3142)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.5.33 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.5.33

Plugin 詳細資訊

嚴重性: Critical

ID: 90007

檔案名稱: php_5_5_33.nasl

版本: 1.14

類型: remote

系列: CGI abuses

已發布: 2016/3/17

已更新: 2019/11/20

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2016-3141

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2016/3/3

弱點發布日期: 2016/3/2

參考資訊

CVE: CVE-2016-3141, CVE-2016-3142

BID: 84271, 84306, 84307, 84348, 84349, 84350, 84351