Debian DSA-3508-1:jasper - 安全性更新

high Nessus Plugin ID 89698
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在操控 JPEG-2000 檔案的程式庫 JasPer 中發現數個弱點。Common Vulnerabilities and Exposures 專案發現下列問題:

- CVE-2016-1577 Jacob Baines 在 jas_iccattrval_destroy 函式中發現一個重複釋放瑕疵。遠端攻擊者可惡意利用此瑕疵,造成使用 JasPer 程式庫的應用程式損毀,或可能以執行該應用程式之使用者的權限執行任意程式碼。

- CVE-2016-2089 Qihoo 360 Codesafe Team 在 jas_matrix_clip 函式中發現一個 NULL 指標解除參照瑕疵。遠端攻擊者可惡意利用此瑕疵,造成使用 JasPer 程式庫的應用程式損毀,進而導致拒絕服務。

- CVE-2016-2116 Tyler Hicks 在 jas_iccprof_createfrombuf 函式中發現一個記憶體洩漏瑕疵。遠端攻擊者可惡意利用此瑕疵,造成 JasPer 程式庫消耗記憶體,進而導致拒絕服務。

解決方案

升級 jasper 套件。

針對舊的穩定發行版本 (wheezy),這些問題已在 1.900.1-13+deb7u4 版本中修正。

針對穩定的發行版本 (jessie),這些問題已在 1.900.1-debian1-2.4+deb8u1 版中修正。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=812978

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816625

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816626

https://security-tracker.debian.org/tracker/CVE-2016-1577

https://security-tracker.debian.org/tracker/CVE-2016-2089

https://security-tracker.debian.org/tracker/CVE-2016-2116

https://packages.debian.org/source/wheezy/jasper

https://packages.debian.org/source/jessie/jasper

https://www.debian.org/security/2016/dsa-3508

Plugin 詳細資訊

嚴重性: High

ID: 89698

檔案名稱: debian_DSA-3508.nasl

版本: 2.6

類型: local

代理程式: unix

已發布: 2016/3/7

已更新: 2021/1/11

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 4.7

CVSS v2

風險因素: Medium

基本分數: 6.8

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

風險因素: High

基本分數: 7.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:jasper, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

修補程式發佈日期: 2016/3/6

參考資訊

CVE: CVE-2016-1577, CVE-2016-2089, CVE-2016-2116

DSA: 3508