VMware ESX 多個弱點 (VMSA-2009-0004) (遠端檢查)

high Nessus Plugin ID 89112
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端主機缺少安全性相關修補程式。

描述

遠端 VMware ESX 主機缺少安全性相關修補程式。因此受到多個弱點影響:

- helptags_one() 函式的 Vim 說明標籤處理器中存在一個格式字串瑕疵,允許遠端攻擊者透過誘騙使用者對惡意說明檔案執行「helptags」命令,執行任意程式碼。(CVE-2007-2953)

- Vim 系統函式中存在多個瑕疵,這是因為無法清理使用者提供的輸入所導致。攻擊者可惡意利用這些瑕疵,誘騙使用者開啟特製的檔案,進而執行任意程式碼。(CVE-2008-2712)

- Vim mch_expand_wildcards() 函式中存在一個堆積型緩衝區溢位情形。攻擊者可惡意利用此情形,透過特製檔案名稱中的 shell 詮釋字元,執行任意程式碼。(CVE-2008-3432)

- 處理 Vim 關鍵字和標籤時存在多個瑕疵,這是因為不當處理逸出字元所導致。攻擊者可惡意利用此問題,透過特製文件,執行任意 shell 命令或 Ex 命令。(CVE-2008-4101)

- OpenSSL 中存在一個安全性繞過弱點,這是因為無法正確檢查來自 EVP_VerifyFinal() 函式的傳回值所導致。遠端攻擊者可惡意利用此弱點,透過適用於 DSA 和 ECDSA 金鑰之格式錯誤的 SSL/TLS 簽章,繞過憑證鏈的驗證。(CVE-2008-5077)

- BIND 中存在一個安全性繞過弱點,這是因為無法正確檢查來自 OpenSSL DSA_verify() 函式的傳回值所導致。遠端攻擊者可惡意利用此弱點,透過格式錯誤的 SSL/TLS 簽章,繞過使用 DNSSEC 之系統中的憑證鏈驗證。(CVE-2009-0025)

解決方案

根據與 ESX 3.5 / 4.0 版有關的供應商公告,套用適當的修補程式。

另請參閱

https://www.vmware.com/security/advisories/VMSA-2009-0004

Plugin 詳細資訊

嚴重性: High

ID: 89112

檔案名稱: vmware_VMSA-2009-0004_remote.nasl

版本: 1.6

類型: remote

系列: Misc.

已發布: 2016/3/3

已更新: 2021/1/6

相依性: vmware_vsphere_detect.nbin

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 7.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/o:vmware:esx

必要的 KB 項目: Host/VMware/version, Host/VMware/release

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2009/3/31

弱點發布日期: 2007/7/27

參考資訊

CVE: CVE-2007-2953, CVE-2008-2712, CVE-2008-3432, CVE-2008-4101, CVE-2008-5077, CVE-2009-0025

BID: 25095, 29715, 30648, 30795, 33150, 33151

VMSA: 2009-0004

CWE: 20, 119, 287