Knot DNS < 1.6.3 多個弱點

high Nessus Plugin ID 87598

Synopsis

遠端 DNS 伺服器受到多個弱點影響。

描述

遠端主機執行的 Knot DNS 版本比 1.6.3 版舊。因此,會受到多個弱點影響:

- knot_rrset_rr_to_canonical() 函式中存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,透過特製封包,洩漏敏感資訊或造成拒絕服務。(OSVDB 120485)

- 區域剖析器中存在一個超出邊界讀取錯誤,這是因不當處理來源網域名稱所導致。未經驗證的遠端攻擊者可惡意利用此弱點,透過特製的區域洩漏敏感資訊或造成拒絕服務。(OSVDB 120486)

- rdata_seek() 函式中存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,透過特製封包,洩漏敏感資訊或造成拒絕服務。(OSVDB 120487)

解決方案

升級至 Knot DNS 1.6.3 或更新版本。

另請參閱

https://gitlab.labs.nic.cz/users/sign_in

Plugin 詳細資訊

嚴重性: High

ID: 87598

檔案名稱: knot_dns_1_6_3.nasl

版本: 1.5

類型: remote

系列: DNS

已發布: 2015/12/22

已更新: 2019/1/2

組態: 啟用 Paranoid 模式

風險資訊

CVSS v2

風險因素: High

基本分數: 8.5

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:C

弱點資訊

CPE: x-cpe:/a:cz.nic:knot_dns

必要的 KB 項目: knot_dns/proto, Settings/ParanoidReport

修補程式發佈日期: 2015/4/8

弱點發布日期: 2015/4/8