dnsmasq 2.73rc6 < 2.73rc8 extract_name() 函式 RCE

critical Nessus Plugin ID 87593

Synopsis

遠端 DNS / DHCP 服務受到遠端程式碼執行弱點影響。

描述

遠端 dnsmasq 伺服器執行的版本為 2.73rc6 或 2.73rc7。因此受到遠端程式碼執行弱點影響,這是因為不當驗證使用者提供的輸入造成 rfc1035.c 中的 extract_name() 函式溢位所致。未經驗證的遠端攻擊者可惡意利用此弱點,藉此造成拒絕服務或執行任意程式碼。

解決方案

升級至 dnsmasq 2.73rc8 或更新版本。

另請參閱

http://www.nessus.org/u?d8b0a30e

http://www.thekelleys.org.uk/dnsmasq/CHANGELOG

Plugin 詳細資訊

嚴重性: Critical

ID: 87593

檔案名稱: dnsmasq_bof-2_73_rc8.nasl

版本: 1.2

類型: remote

系列: DNS

已發布: 2015/12/22

已更新: 2018/8/10

組態: 啟用 Paranoid 模式

風險資訊

CVSS v2

風險因素: Critical

基本分數: 10

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

弱點資訊

CPE: cpe:/a:thekelleys:dnsmasq

必要的 KB 項目: dns_server/version, Settings/ParanoidReport

修補程式發佈日期: 2015/5/15

弱點發布日期: 2015/5/15