Mac OS X:OS X Server < 5.0.3 多個弱點

critical Nessus Plugin ID 86066
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端主機缺少一個適用於 OS X 伺服器的安全性更新。

描述

遠端 Mac OS X 主機上安裝的 OS X Server 為 5.0.3 之前的版本。因此受到以下弱點影響:

- mod_headers 模組中存在一個瑕疵,其允許在要求處理後期以 HTTP 結尾取代 HTTP 標頭。遠端攻擊者可惡意利用此弱點插入任意標頭。這還可能導致部分模組無法正常運作,或是似乎不正常運作。
(CVE-2013-5704)

- 存在一個權限提升弱點,是因 'make check’ 命令未正確叫用 initdb 來為資料庫叢集指定供測試之用的驗證需求所導致。本機攻擊者可惡意利用此問題,藉此取得暫時伺服器存取權和提升的權限。(CVE-2014-0067)

- 模組 mod_cache 中存有一個 NULL 指標解除參照瑕疵。遠端攻擊者可使用空白的 HTTP 內容類型標頭來惡意利用此弱點,藉此損毀快取正向 Pproxy 組態,若使用階層式 MPM 則會導致拒絕服務。
(CVE-2014-3581)

- 模組 mod_proxy_fcgi 中存有一個超出邊界記憶體讀取瑕疵。攻擊者可使用遠端 FastCGI 伺服器傳送長回應時間標頭來惡意利用此弱點,導致緩衝區過度讀取因而造成拒絕服務。(CVE-2014-3583)

- 處理具有不同引數的多個 Require 指示詞中使用的 LuaAuthzProvider 時,模組 mod_lua 中存有瑕疵。攻擊者可惡意利用此弱點,藉此繞過預定的存取限制。
(CVE-2014-8109)

- 存在一個資訊洩漏弱點,是因不當處理限制違規錯誤訊息中的受限欄值所導致。經驗證的遠端攻擊者可利用此弱點取得敏感資訊的存取權。(CVE-2014-8161)

- 網域名稱服務中存有一個瑕疵,這是因為用於遵循委派的程式碼出錯而引起的。遠端攻擊者若擁有惡意建構的區域或查詢,就能造成服務發出無限制的查詢,進而導致資源耗盡。(CVE-2014-8500)

- 由於不正確處理 WebSocket PING 框架,而導致「mod_lua」模組中的 lua_websocket_read() 函式出現一個瑕疵。遠端攻擊者可惡意利用這點,在 Lua 指令碼呼叫 wsupgrade() 函式之後傳送特製的 WebSocket PING 框架,造成子處理程序損毀,進而導致拒絕服務情形。(CVE-2015-0228)

- 存在多個弱點,是因與「to_char」函式有關的多個緩衝區溢位錯誤所導致。經驗證的遠端攻擊者可惡意利用這些問題,造成拒絕服務或任意程式碼執行。(CVE-2015-0241)

- 存在多個弱點,是因多種 *printf() 函式中的數個堆疊型緩衝區溢位錯誤所導致。溢位發生的原因是格式化浮點數時 (要求的準確度高於大約 500) 不當驗證使用者提供的輸入。經驗證的遠端攻擊者可惡意利用這些問題,造成拒絕服務或任意程式碼執行。(CVE-2015-0242)

- 存在多個弱點,是因「pgcrypto」延伸模組中的數個函式發生溢位情形所導致。溢位發生的原因是追蹤記憶體大小時不當驗證使用者提供的輸入。經驗證的遠端攻擊者可惡意利用這些問題,造成拒絕服務或任意程式碼執行。(CVE-2015-0243)

- 存在 SQL 插入弱點,是因處理命令參數中的特製二進位資料時,不當清理使用者提供的輸入所導致。經驗證的遠端攻擊者可惡意利用此問題來插入或操控 SQL 查詢,進而允許操控或洩漏任意資料。
(CVE-2015-0244)

- read_request_line() 函式中存在因無法初始化通訊協定結構成員所致的 NULL 指標解除參照瑕疵。遠端攻擊者可惡意利用此瑕疵,針對啟用了 INCLUDES 篩選器且具有指定本機 URI 之 ErrorDocument 400 指示詞的安裝,傳送缺少方法的要求,造成拒絕服務情形。(CVE-2015-0253)

- 存在一個拒絕服務弱點,是因與 DNSSEC 驗證和受管理金鑰功能有關的錯誤所導致。遠端攻擊者可觸發錯誤的信任錨點管理狀況,該狀況下無任何就緒金鑰可供使用,進而導致宣告失敗和程序損毀。(CVE-2015-1349)

- PostgreSQL 用戶端中斷連線逾時到期存在一個瑕疵,該瑕疵會在工作階段關機序列過程中發生逾時中斷時觸發。(CVE-2015-3165)

- printf() 函式中存在一個瑕疵,這是因為檢查錯誤失敗所致。遠端攻擊者可利用此瑕疵取得敏感資訊的存取權。(CVE-2015-3166)

- 針對具有錯誤金鑰的解密,PostgreSQL 的 pgcrypto 元件有多個錯誤訊息。遠端攻擊者可加以惡意利用,藉此從其他系統還原金鑰。(CVE-2015-3167)

- 在區塊傳輸編碼實作中,存在因無法正確剖析區塊標頭所致的瑕疵。遠端攻擊者可惡意利用這點,發動 HTTP 要求走私攻擊。(CVE-2015-3183)

- 在 ap_some_auth_required() 函式中,存在因無法考慮 Require 指示詞可能與授權設定而非驗證設定相關聯所致的瑕疵。如果依賴 2.2 API 行為的模組存在,遠端攻擊者可惡意利用這點,繞過預定的存取限制。
(CVE-2015-3185)

- 以 Twisted 為基礎的 Wiki Server 中存在多個不明 XML 瑕疵。(CVE-2015-5911)

解決方案

升級至 Mac OS X Server 5.0.3 或更新版本。

請注意,OS X Server 5.0.3 僅適用於 OS X 10.10.5 或更新版本。

另請參閱

https://support.apple.com/en-us/HT205219

http://www.nessus.org/u?b8a8a151

Plugin 詳細資訊

嚴重性: Critical

ID: 86066

檔案名稱: macosx_server_5_0_3.nasl

版本: 1.9

類型: local

代理程式: macosx

已發布: 2015/9/22

已更新: 2019/11/22

相依性: macosx_server_services.nasl

風險資訊

CVSS 評分資料來源: CVE-2015-5911

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/o:apple:mac_os_x_server

必要的 KB 項目: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Server/Version

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2015/9/16

弱點發布日期: 2015/9/16

參考資訊

CVE: CVE-2013-5704, CVE-2014-0067, CVE-2014-3581, CVE-2014-3583, CVE-2014-8109, CVE-2014-8161, CVE-2014-8500, CVE-2015-0228, CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, CVE-2015-0244, CVE-2015-0253, CVE-2015-1349, CVE-2015-3165, CVE-2015-3166, CVE-2015-3167, CVE-2015-3183, CVE-2015-3185, CVE-2015-5911

BID: 65721, 66550, 71590, 71656, 71657, 72538, 72540, 72542, 72543, 72673, 73040, 73041, 74787, 74789, 74790, 75963, 75964, 75965

APPLE-SA: APPLE-SA-2015-09-16-4