Apache ActiveMQ Blob 訊息目錄遊走

medium Nessus Plugin ID 85580

Synopsis

遠端主機上的 web 應用程式受到目錄遊走弱點影響。

描述

遠端主機上安裝的 Apache ActiveMQ 版本受到目錄遊走弱點影響,這是因為不當處理清理使用者在檔案伺服器上傳和下載功能中提供的輸入所致。未經驗證的遠端攻擊者可加以惡意利用,透過特製要求,讀取並上傳任意 JSP 檔案,進而導致任意命令執行。

解決方案

升級至 Apache ActiveMQ 5.11.2 / 5.12.0 或更新版本。或者,套用供應商建議的減輕指示。

另請參閱

http://www.nessus.org/u?ed82104f

Plugin 詳細資訊

嚴重性: Medium

ID: 85580

檔案名稱: activemq_fileserver_directory_traversal.nasl

版本: 1.10

類型: remote

系列: CGI abuses

已發布: 2015/8/21

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 4.9

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 4.1

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:F/RL:OF/RC:ND

CVSS 評分資料來源: CVE-2015-1830

弱點資訊

CPE: cpe:/a:apache:activemq

必要的 KB 項目: installed_sw/ActiveMQ

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2015/8/17

弱點發布日期: 2015/8/17

惡意利用途徑

Core Impact

參考資訊

CVE: CVE-2015-1830