PHP 5.6.x < 5.6.12 多個弱點

high Nessus Plugin ID 85300
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端 Web 伺服器上安裝的 PHP 版本為 5.6.12 之前的 5.6.x 版。因此,會受到多個弱點影響:

- 檔案 spl_dllist.c 存在一個釋放後使用錯誤,是因不當清理 unserialize() 函式的輸入所導致。攻擊者可加以惡意利用,使用特製的 SplDoublyLinkedList 物件來解除參照釋放的記憶體,並藉此執行任意程式碼。
(OSVDB 125849)

- 檔案 spl_observer.c 存在一個釋放後使用錯誤,是因不當清理 unserialize() 函式的輸入所導致。攻擊者可加以惡意利用,使用特製的 SplObjectStorage 物件來解除參照釋放的記憶體,並藉此執行任意程式碼。
(OSVDB 125850)

- 檔案 spl_array.c 存在一個釋放後使用錯誤,是因不當清理 unserialize() 函式的輸入所導致。攻擊者可加以惡意利用,使用特製的 SplArrayObject 物件來解除參照釋放的記憶體,並藉此執行任意程式碼。
(OSVDB 125851)

- 檔案 zend_exceptions.c 中存在一個瑕疵,是因遞迴方法呼叫期間不當使用 unserialize() 函式所導致。遠端攻擊者可加以惡意利用,造成使用 PHP 的應用程式損毀。(OSVDB 125852)

- 檔案 zend_exceptions.c 中存在一個瑕疵,是因 unserialize() 和 __toString() 函式的類型檢查不充分所導致。遠端攻擊者可加以惡意利用,造成 NULL 指標解除參照或未預期的方法執行,進而導致使用 PHP 的應用程式損毀。(OSVDB 125853)

- 檔案 phar_object.c 中存在一個路徑遊走瑕疵,是因不當清理使用者提供的輸入所導致。攻攻擊者可加以惡意利用,藉此寫入任意檔案。
(OSVDB 125854)

- 處理 zend_hash_get_current_key 或 ‘Z*’ 呼叫時,檔案 php_http.c 的 _call() 方法中存在多個類型混淆瑕疵。攻擊者可加以惡意利用,洩漏記憶體內容或造成使用 PHP 的應用程式損毀。(OSVDB 125855)

- 檔案 spl_array.c 中存在一個懸置指標錯誤,是因不當清理 unserialize() 函式的輸入所導致。攻擊者可加以惡意利用,使用特製的 SplDoublyLinkedList 物件來取得解除配置的指標控制權,並藉此執行任意程式碼。(OSVDB 125856)

- 檔案 gd.c 中存在一個瑕疵,這是因為 imagefilltoborder() 函式不當處理含有極大負值座標的影像所導致。攻擊者可惡意利用此瑕疵造成堆疊溢位,並導致使用 PHP 的應用程式損毀。(OSVDB 125857)

- odbc_fetch_array() 函式處理定義為 NVARCHAR(MAX) 的欄時,檔案 php_odbc.c 中存在一個瑕疵。攻擊者可惡意利用此瑕疵,造成使用 PHP 的應用程式損毀。(OSVDB 125858)

- 檔案 openssl.c 中,openssl_random_pseudo_bytes() 函式並未充分產生亂數。
這會讓攻擊者能更輕易地預測結果,進而允許發動進一步攻擊。(OSVDB 125859)

- spl_observer.c 的 unserialize() 函式中存在一個釋放後使用錯誤,這是因為不當驗證使用者提供的輸入所導致。遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,可能進而導致任意程式碼執行。
(OSVDB 126951)

- soap.c 的 serialize_function_call() 函式中存在一個類型混淆瑕疵,是因不當驗證透過標頭欄位傳遞的輸入所導致。遠端攻擊者可惡意利用這點,執行任意程式碼。(OSVDB 126952)

- spl_dllist.c 的 unserialize() 函式中存在一個釋放後使用錯誤,該錯誤會在還原序列化使用者提供的輸入期間觸發。遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,可能進而導致任意程式碼執行。(OSVDB 126954)

- gmp.c 的 gmp_unserialize() 函式中存在一個釋放後使用錯誤,這是因為不當驗證使用者提供的輸入所導致。遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,可能進而導致任意程式碼執行。
(OSVDB 126960)

- zend_hash.c 的 zend_hash_compare() 函式中存在一個整數截斷瑕疵,該瑕疵會在比較陣列時觸發。遠端攻擊者可加以惡意利用,造成比較期間系統不當比對陣列。(OSVDB 127367)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.6.12 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.6.12

https://seclists.org/fulldisclosure/2015/Aug/17

https://seclists.org/fulldisclosure/2015/Aug/18

https://seclists.org/fulldisclosure/2015/Aug/19

https://bugs.php.net/bug.php?id=69793

https://bugs.php.net/bug.php?id=70121

Plugin 詳細資訊

嚴重性: High

ID: 85300

檔案名稱: php_5_6_12.nasl

版本: 1.13

類型: remote

系列: CGI abuses

已發布: 2015/8/11

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2015-6831

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2015/8/6

弱點發布日期: 2014/1/2

參考資訊

CVE: CVE-2015-6831, CVE-2015-6832, CVE-2015-6833, CVE-2015-8867, CVE-2015-8874, CVE-2015-8879

BID: 76735, 76737, 76739, 87481, 90714, 90842