Apache 2.4.x < 2.4.16 多個弱點

medium Nessus Plugin ID 84959

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

根據其標題,遠端主機上安裝的 Apache 2.4.x 版比 2.4.16 舊。因此,該應用程式受到以下弱點影響:

- 由於不正確處理 WebSocket PING 框架,而導致「mod_lua」模組中的 lua_websocket_read() 函式出現一個瑕疵。遠端攻擊者可利用此缺陷,在 Lua 指令碼呼叫 wsupgrade() 函式之後傳送特別建構的 WebSocket PING 框架,造成子處理程序損毀,進而導致拒絕服務情形。(CVE-2015-0228)

- read_request_line() 函式中存在因無法初始化通訊協定結構成員所致的 NULL 指標解除參照瑕疵。遠端攻擊者可利用此缺陷,針對啟用了 INCLUDES 篩選器且具有指定本機 URI 之 ErrorDocument 400 指示詞的安裝,傳送缺少方法的要求,造成拒絕服務情形。(CVE-2015-0253)

- 在區塊傳輸編碼實作中,存在因無法正確剖析區塊標頭所致的瑕疵。遠端攻擊者可惡意利用此缺陷,發動 HTTP 要求走私攻擊。(CVE-2015-3183)

- 在 ap_some_auth_required() 函式中,存在因無法考慮 Require 指示詞可能與授權設定而非驗證設定相關聯所致的瑕疵。如果依賴 2.2 API 行為的模組存在,遠端攻擊者可惡意利用這點,繞過預定的存取限制。
(CVE-2015-3185)

- RC4 演算法中存在一個瑕疵,這是因為產生金鑰串流過程中的初始雙位元組偏差所導致。攻擊者可惡意利用此瑕疵,透過整合 priori 純文字發行和金鑰串流發行統計資料的 Bayesian 分析,發動加密文字的純文字復原。請注意,根據 RFC 7465 禁止 RC4 加密套件。此問題已在 Apache 2.4.13 版中修正;不過,從未公開發佈 2.4.13、2.4.14 和 2.4.15。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.16 或更新版本。此外,請確保受影響的模組目前未處於使用中。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.16

http://httpd.apache.org/security/vulnerabilities_24.html

http://www.nessus.org/u?7ec9a07a

https://tools.ietf.org/html/rfc7465

Plugin 詳細資訊

嚴重性: Medium

ID: 84959

檔案名稱: apache_2_4_16.nasl

版本: 1.18

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2015/7/23

已更新: 2022/4/11

支持的傳感器: Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2015-3183

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2015/7/15

弱點發布日期: 2015/2/3

參考資訊

CVE: CVE-2015-0228, CVE-2015-0253, CVE-2015-3183, CVE-2015-3185

BID: 73041, 75963, 75964, 75965