Squid 3.2 < 3.5.4 不正確 X509 伺服器憑證驗證弱點

low Nessus Plugin ID 83529
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Proxy 伺服器可能受到憑證驗證弱點影響。

描述

根據其標題,遠端主機上執行的 Squid 版本是比 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4 舊的 3.2。因此可能受到與憑證驗證相關的一個瑕疵影響,這是因為未驗證伺服器主機名稱是否與憑證主體之共用名稱 (CN) 或 SubjectAltName 欄位中的網域名稱相符所導致。攔截式攻擊者可惡意利用此瑕疵,使用特製的憑證偽造 TLS/SSL 伺服器,進而允許洩漏或操控攔截的資料。請注意,只有當您將 Squid 設為使用「用戶端優先」或「提升」作業模式來執行 SSL 提升後,此瑕疵才可能遭到惡意利用。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。為解決此問題而發佈的修補程式不會更新標題中的版本。如果已正確套用修補程式並重新啟動服務,請將此情況視為誤判。

解決方案

升級至 Squid 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4 版本,或者套用供應商提供的修補程式。

另請參閱

http://www.squid-cache.org/Advisories/

http://www.squid-cache.org/Advisories/SQUID-2015_1.txt

http://www.nessus.org/u?8ef2aa9b

Plugin 詳細資訊

嚴重性: Low

ID: 83529

檔案名稱: squid_3_5_4.nasl

版本: 1.4

類型: remote

系列: Firewalls

已發布: 2015/5/19

已更新: 2019/11/22

相依性: squid_version.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2015-3455

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Low

基本分數: 2.6

時間分數: 1.9

媒介: AV:N/AC:H/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:squid-cache:squid

必要的 KB 項目: www/squid, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2015/5/1

弱點發布日期: 2015/5/1

參考資訊

CVE: CVE-2015-3455

BID: 74438