PHP 5.6.x < 5.6.9 多個弱點

critical Nessus Plugin ID 83519
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端 Web 伺服器上執行的 PHP 5.6.x 版本比 5.6.9 版舊。因此,會受到多個弱點影響:

- 存有多個與使用含有 NULL 位元組的路徑名稱有關的瑕疵。遠端攻擊者可利用這些瑕疵,結合使用「\0」字元和安全的副檔名,進而繞過存取限制。這在之前已經修正,但又因為 5.4+ 版的迴歸問題而再次出現。(CVE-2006-7243、CVE-2015-4025)

- ftp.c. 中的 ftp_genlist() 函式中存在一個整數溢位情形,這是因為不當驗證使用者提供的輸入所導致。遠端攻擊者可惡意利用此問題造成堆積型緩衝區溢位,從而引發拒絕服務情形,或可能造成遠端程式碼執行。(CVE-2015-4022)

- rfc1867.c 的 multipart_buffer_headers() 函式存有一個瑕疵,造成此瑕疵的原因是不當處理 HTTP 要求中的 multipart/form-data。遠端攻擊者可利用此瑕疵,導致 CPU 資源消耗,從而引發拒絕服務的情況。
(CVE-2015-4024)

- 存有一個因 pcntl_exec 實作中存有一個瑕疵而引起的安全性繞過弱點,這會在遇到「\x00」字元的時候截斷路徑名稱。遠端攻擊者可利用此弱點,透過特製的第一個引數,進而繞過預定的延伸模組限制,並且執行任意檔案。(CVE-2015-4026)

- xsltprocessor.c 之 xsl_ext_function_php() 函式中存在一個 NULL 指標解除參照瑕疵,這是因為不當驗證使用者提供的輸入所導致。遠端攻擊者可加以惡意利用,進而引發拒絕服務的情況。(OSVDB 126989)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.6.9 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.6.9

Plugin 詳細資訊

嚴重性: Critical

ID: 83519

檔案名稱: php_5_6_9.nasl

版本: 1.15

類型: remote

系列: CGI abuses

已發布: 2015/5/18

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2015-4026

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/5/14

弱點發布日期: 2006/12/18

參考資訊

CVE: CVE-2006-7243, CVE-2015-2325, CVE-2015-2326, CVE-2015-4021, CVE-2015-4022, CVE-2015-4024, CVE-2015-4025, CVE-2015-4026

BID: 44951, 74700, 74902, 74903, 74904, 75056, 75174, 75175