Apache Struts 2.3.20 錯誤預設排除模式

high Nessus Plugin ID 83487

Synopsis

遠端 web 伺服器主控的一個 web 應用程式使用含有錯誤預設排除模式的 Java 架構。

描述

遠端 web 伺服器正在使用 Apache Struts 2.3.20 版。因此會受到一個問題影響,即使用預設設定時預設的排除模式不正確。這會允許遠端攻擊者影響內部應用程式的狀態。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.3.20.1 或更新版本。

另請參閱

https://cwiki.apache.org/confluence/display/WW/S2-024

Plugin 詳細資訊

嚴重性: High

ID: 83487

檔案名稱: struts_2_3_20_1_win_local.nasl

版本: 1.14

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2015/5/15

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.4

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2015-1831

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:struts

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/5/6

弱點發布日期: 2015/5/6

參考資訊

CVE: CVE-2015-1831