Siemens SCALANCE S612 防火牆 > 2.1 和 < 2.3.0.3 多個弱點 (SSA-268149)

critical Nessus Plugin ID 83263

概要

遠端 Siemens SCALANCE S612 防火牆受到多個弱點影響。

說明

Siemens SCALANCE S612 防火牆裝置的韌體版本為 2.1 之後且 2.3.0.3 之前版本。因此,該應用程式受到以下弱點影響:

- 存在一個暴力密碼破解弱點,這是因為無法強制執行失敗登入嘗試之間的時間延遲所致。這可讓遠端攻擊者在很短的時間範圍內執行多次快速驗證嘗試。
(CVE-2012-1799)
- 在 Profinet DCP 通訊協定實作中存在一個堆疊型緩衝區溢位弱點,這是因為無法正確處理不明輸入所致。遠端攻擊者可利用特製的 DCP 框架,損毀 DCP 通訊協定堆疊,進而造成拒絕服務情形或可能執行任意程式碼。
(CVE-2012-1800)

解決方案

升級至韌體 2.3.0.3 版或更新版本。

另請參閱

http://www.nessus.org/u?754db467

http://www.nessus.org/u?7589cf1c

https://ics-cert.us-cert.gov/advisories/ICSA-12-102-05

Plugin 詳細資訊

嚴重性: Critical

ID: 83263

檔案名稱: scada_siemens_scalance_s612_SSA-268149.nbin

版本: 1.88

類型: remote

系列: SCADA

已發布: 2015/5/6

已更新: 2024/7/17

支援的感應器: Nessus

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

弱點資訊

CPE: cpe:/a:siemens:scalance_s_firmware, cpe:/h:siemens:scalance_s612

必要的 KB 項目: SCADA/Siemens SCALANCE S612 Web Server

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2012/4/5

弱點發布日期: 2012/4/5

參考資訊

CVE: CVE-2012-1799, CVE-2012-1800

BID: 52923

ICSA: 12-102-05