PHP 5.4.x < 5.4.40 多個弱點

critical Nessus Plugin ID 83033

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端 Web 伺服器上執行的 PHP 5.4.x 版本比 5.4.40 版舊。因此,會受到多個弱點影響:

- 在「gd_gif_in.c」檔案中的 GetCode_() 函式中存在一個超出邊界讀取溢位錯誤,這會允許拒絕服務攻擊或記憶體內容洩漏。(CVE-2014-9709)

- 在 PostgreSQL 延伸模組中,「pgsql.c」檔案的 build_tablename() 函式未正確驗證表格名稱的 token 擷取。遠端攻擊者可能會利用特製的名稱惡意利用此弱點,造成 NULL 指標解除參照,進而引發拒絕服務。
(CVE-2015-1352)

- 「phar_object.c」檔案的 phar_rename_archive() 函式中存在一個釋放後使用錯誤。若遠端攻擊者嘗試將 phar 封存重新命名為已存在的檔案名稱,就可能會惡意利用此弱點引發拒絕服務。(CVE-2015-2301)

- Phar 元件中存在一個緩衝區讀取溢位錯誤,這是因為在 unserialize() 函式呼叫過程中處理 phar 剖析時,不當驗證使用者提供的輸入所致。攻擊者可利用這點執行任意程式碼,或造成拒絕服務。
(CVE-2015-2783)

- 在處理封存檔案 (如:tar、zip 或 phar 檔案) 時,「phar_internal.h」檔案的 phar_set_inode() 函式中存在一個緩衝區溢位瑕疵。遠端攻擊者可能會惡意利用此弱點執行任意程式碼,或是引發拒絕服務。(CVE-2015-3329)

- 處理管線 HTTP 要求時,Apache2handler SAPI 元件中存在一個瑕疵,遠端攻擊者可惡意利用此瑕疵執行任意程式碼。(CVE-2015-3330)

- 存在多個記憶體損毀瑕疵,這是因為不當驗證使用者提供的輸入所導致。遠端攻擊者可能會惡意利用這些問題,進而引發拒絕服務情形。(CVE-2015-4601)

- incomplete_class.c 中存在一個記憶體損毀瑕疵,這是因為不當驗證使用者提供的輸入所致。遠端攻擊者可能會惡意利用此瑕疵,進而洩漏敏感資訊,或是引發拒絕服務情形。(CVE-2015-4602)

- 存在一個因「exception::getTraceAsString」中出現一個不明瑕疵而造成的拒絕服務弱點。遠端攻擊者可能會惡意利用此瑕疵,造成應用程式損毀。(CVE-2015-4603)

- softmagic.c 的隨附 libmagic 程式庫中存在一個拒絕服務弱點。遠端攻擊者可能會惡意利用此瑕疵,造成應用程式損毀。
(CVE-2015-4604)

- 存在一個拒絕服務弱點,這是因為 softmagic.c 中 mcopy() 函式的隨附 libmagic 程式庫有一瑕疵所致。函式無法正確處理超過‘bytecnt’的位移。遠端攻擊者可能會惡意利用此弱點,透過特製的字串引發拒絕服務情形。(CVE-2015-4605)

請注意,Nessus 並未嘗試惡意利用這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.4.40 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.4.40

Plugin 詳細資訊

嚴重性: Critical

ID: 83033

檔案名稱: php_5_4_40.nasl

版本: 1.20

類型: remote

系列: CGI abuses

已發布: 2015/4/23

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/4/16

弱點發布日期: 2014/12/13

參考資訊

CVE: CVE-2014-9709, CVE-2015-1352, CVE-2015-2301, CVE-2015-2783, CVE-2015-3307, CVE-2015-3329, CVE-2015-3330, CVE-2015-3411, CVE-2015-3412, CVE-2015-4599, CVE-2015-4600, CVE-2015-4601, CVE-2015-4602, CVE-2015-4603, CVE-2015-4604, CVE-2015-4605

BID: 71932, 73037, 73306, 74204, 74239, 74240, 74413, 74703, 75233, 75241, 75246, 75249, 75250, 75251, 75252, 75255