PHP 5.5.x < 5.5.23 多個弱點

critical Nessus Plugin ID 82026

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據遠端主機的標題,其安裝的 PHP 5.5.x 版本比 5.5.23 舊。因此,會受到多個弱點影響:

- 存在一個與函式‘unserialize’相關的釋放後使用錯誤,這可能會讓遠端攻擊者得以執行任意程式碼。請注意,此問題是因為 CVE-2014-8142 修正不完整所致。(CVE-2015-0231)

- Henry Spencer regex 程式庫的函式「regcomp」中存在一個整數溢位錯誤,這是因為不當驗證使用者提供的輸入所致。攻擊者可能會加以惡意利用,進而引發拒絕服務,或執行任意程式碼。(CVE-2015-2305)

-「_zip_cdir_new」函式中存在一個整數溢位錯誤,這是因為不當驗證使用者提供的輸入所致。攻擊者可能會利用特製 ZIP 封存檔來加以惡意利用,進而引發拒絕服務或執行任意程式碼。(CVE-2015-2331)

- 存在一個篩選繞過弱點,原因在於 move_uploaded_file() 函式中存在一個瑕疵,會讓路徑名稱在遇到 NULL 位元組時遭到截斷。這讓遠端攻擊者得以透過特製的第二個引數,來繞過預定的延伸模組限制,並建立名稱非預期的檔案。(CVE-2015-2348)

- process_nested_data() 函式中存在一個釋放後使用錯誤。這會讓遠端攻擊者透過特製的 unserialize 呼叫,使已經釋放的記憶體解除參照,進而引發任意程式碼執行。(CVE-2015-2787)

請注意,Nessus 並未嘗試惡意利用這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.5.23 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.5.23

https://bugs.php.net/bug.php?id=69207

https://bugs.php.net/bug.php?id=68976

Plugin 詳細資訊

嚴重性: Critical

ID: 82026

檔案名稱: php_5_5_23.nasl

版本: 1.17

類型: remote

系列: CGI abuses

已發布: 2015/3/24

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: High

分數: 8.8

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2015-4147

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 9.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/3/19

弱點發布日期: 2014/12/18

參考資訊

CVE: CVE-2015-0231, CVE-2015-2305, CVE-2015-2331, CVE-2015-2348, CVE-2015-2787, CVE-2015-4147, CVE-2015-4148

BID: 72539, 73182, 73357, 73381, 73383, 73385, 73431, 73434, 75103