Oracle Linux 6 / 7 : freetype (ELSA-2015-0696)

high Nessus Plugin ID 81902
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

來自 Red Hat 安全性公告 2015:0696:

現已提供適用於 Red Hat Enterprise Linux 6 和 7 的更新版 freetype 套件,可修正多個安全性問題。

Red Hat 產品安全性團隊已將此更新評等為具有重要安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

FreeType 是免費、高品質的可攜式字型引擎,可開啟及管理字型檔。它也可以有效載入、提示及轉譯個別字符。

在 FreeType 處理 Mac 字型的方式中發現多個整數溢位瑕疵和一個整數正負號瑕疵,這會導致堆積型緩衝區溢位。如果使用 FreeType 連結的應用程式載入了特製的字型檔案,可導致應用程式損毀,或可能利用執行應用程式之使用者的權限來執行任意程式碼。(CVE-2014-9673、CVE-2014-9674)

在 FreeType 處理多種格式之字型的方式中發現多個瑕疵。如果使用 FreeType 連結的應用程式載入特製的字型檔案,可能導致應用程式損毀,或可能洩漏部分的應用程式記憶體。
(CVE-2014-9657、CVE-2014-9658、CVE-2014-9660、CVE-2014-9661、CVE-2014-9663、CVE-2014-9664、CVE-2014-9667、CVE-2014-9669、CVE-2014-9670、CVE-2014-9671、CVE-2014-9675)

建議所有 freetype 使用者皆升級至這些更新版套件,其中包含可更正這些問題的反向移植修補程式。必須重新啟動 (登出,接著重新登入) X 伺服器,此更新才能生效。

解決方案

更新受影響的 freetype 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2015-March/004909.html

https://oss.oracle.com/pipermail/el-errata/2015-March/004910.html

Plugin 詳細資訊

嚴重性: High

ID: 81902

檔案名稱: oraclelinux_ELSA-2015-0696.nasl

版本: 1.10

類型: local

代理程式: unix

已發布: 2015/3/18

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:freetype, p-cpe:/a:oracle:linux:freetype-demos, p-cpe:/a:oracle:linux:freetype-devel, cpe:/o:oracle:linux:6, cpe:/o:oracle:linux:7

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2015/3/17

弱點發布日期: 2015/2/8

參考資訊

CVE: CVE-2014-9657, CVE-2014-9658, CVE-2014-9660, CVE-2014-9661, CVE-2014-9663, CVE-2014-9664, CVE-2014-9667, CVE-2014-9669, CVE-2014-9670, CVE-2014-9671, CVE-2014-9673, CVE-2014-9674, CVE-2014-9675

RHSA: 2015:0696