phpMyAdmin 4.0.x < 4.0.10.9 / 4.2.x < 4.2.13.2 / 4.3.x < 4.3.11.1 資訊洩漏弱點 (PMASA-2015-1)

medium Nessus Plugin ID 81818
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 web 伺服器主控的 PHP 應用程式受到一個資訊洩漏弱點影響。

描述

根據其自我報告的版本號碼,遠端 Web 伺服器上主控的 phpMyAdmin 應用程式為 4.0.10.9 之前的 4.0.x 版、 4.2.13.2 之前的 4.2.x 版或 4.3.11.1 之前的 4.3.x 版。因此受到資訊洩漏弱點影響,這是因為未隱藏壓縮 HTTPS 回應之長度所導致。這會允許遠端攻擊者利用一連串特製的要求,透過 BREACH 攻擊取得 CSRF token。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 phpMyAdmin 4.0.10.9 / 4.2.13.2 / 4.3.11.1 或更新版本,或是套用供應商公告中提及的修補程式。

另請參閱

http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

http://www.nessus.org/u?a4cc2198

http://www.nessus.org/u?11d0e38d

http://www.nessus.org/u?4b01e679

Plugin 詳細資訊

嚴重性: Medium

ID: 81818

檔案名稱: phpmyadmin_pmasa_2015_1.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2015/3/13

已更新: 2021/1/19

相依性: phpMyAdmin_detect.nasl

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Low

分數: 2.5

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要的 KB 項目: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/3/4

弱點發布日期: 2015/3/4

參考資訊

CVE: CVE-2015-2206

BID: 72949