Apache 2.4.x < 2.4.12 多個弱點

medium Nessus Plugin ID 81126
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

根據其標題,遠端主機上執行的 Apache 2.4.x 版本比 2.4.12 舊。因此,該應用程式受到以下弱點影響:

- 模組 mod_headers 中存有瑕疵,可允許 HTTP 結尾在處理要求後期取代 HTTP 標頭,遠端攻擊者可惡意利用此瑕疵,藉此插入任意標頭。這還可能導致部分模組無法正常運作,或是似乎不正常運作。(CVE-2013-5704)

- 模組 mod_cache 中存有一個 NULL 指標解除參照瑕疵。遠端攻擊者可使用空白的 HTTP 內容類型標頭來惡意利用此弱點,藉此損毀快取正向 Pproxy 組態,若使用階層式 MPM 則會導致拒絕服務。
(CVE-2014-3581)

- 模組 mod_proxy_fcgi 中存有一個超出邊界記憶體讀取瑕疵。攻擊者可利用此弱點,透過使用遠端 FastCGI 伺服器傳送長回應時間標頭,導致緩衝區過度讀取,進而造成拒絕服務。(CVE-2014-3583)

- 處理具有不同引數的多個 Require 指示詞中使用的 LuaAuthzProvider 時,模組 mod_lua 中存有瑕疵。攻擊者可惡意利用此弱點,藉此繞過預定的存取限制。
(CVE-2014-8109)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.12 或更新版本。此外,請確保受影響的模組目前未處於使用中。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.12

http://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: Medium

ID: 81126

檔案名稱: apache_2_4_12.nasl

版本: 1.15

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2015/2/2

已更新: 2021/1/28

相依性: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

風險資訊

CVSS 評分資料來源: CVE-2013-5704

VPR

風險因素: Medium

分數: 4.5

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2015/1/30

弱點發布日期: 2013/10/19

參考資訊

CVE: CVE-2013-5704, CVE-2014-3581, CVE-2014-3583, CVE-2014-8109

BID: 66550, 71656, 71657, 73040