PHP 5.4.x < 5.4.37 多個弱點

high Nessus Plugin ID 81080

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據遠端主機的標題,其安裝的 PHP 5.4.x 版本比 5.4.37 舊。因此受到多個弱點影響:

- nmap 用於處理以雜湊字元 (#) 開頭但缺少新行字元的無效檔案時,CGI 元件在檔案「cgi_main.c」中有一個超出邊界讀取瑕疵。遠端攻擊者可使用特製的 PHP 檔案惡意利用此弱點,藉此洩漏記憶體內容,進而造成拒絕服務或可能執行程式碼。(CVE-2014-9427)

- 'var_unserializer.re' 內的 'process_nested_data' 函式中存在一個釋放後使用記憶體錯誤,原因是不當處理物件序列化內容中的重複數值金鑰。遠端攻擊者可使用特製的還原序列化方法呼叫來惡意利用此弱點,造成任意程式碼執行。
(CVE-2015-0231)

- 'exif.c' 內的 'exif_process_unicode' 函式中存在一個瑕疵,會允許釋放未初始化的指標。遠端攻擊者可利用 JPEG 影像中特製的 EXIF 資料來惡意利用此問題,造成拒絕服務或是執行任意程式碼。(CVE-2015-0232)

請注意,Nessus 並未嘗試惡意利用這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.4.37 或更新版本。

另請參閱

http://php.net/ChangeLog-5.php#5.4.37

https://bugs.php.net/bug.php?id=68618

https://bugs.php.net/bug.php?id=68710

https://bugs.php.net/bug.php?id=68799

Plugin 詳細資訊

嚴重性: High

ID: 81080

檔案名稱: php_5_4_37.nasl

版本: 1.17

類型: remote

系列: CGI abuses

已發布: 2015/1/29

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2014-9427

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/1/22

弱點發布日期: 2014/12/17

參考資訊

CVE: CVE-2014-9427, CVE-2014-9652, CVE-2015-0231, CVE-2015-0232

BID: 71833, 72505, 72539, 72541